Pi 4 won't boot downloaded Volumio image


Volumio Information

Volumio Version: 2.882
Hardware: Pi 4 2GB
DAC: none

Debug Log

Can’t get any, Volumio won’t start properly

Steps to Reproduce

  1. Burn downloaded 2.882 image onto SD with Balena Etcher
  2. Make sure Pi 4 is running EEPROM v2021-04-29
  3. Insert SD into Pi 4
  4. Connect power
  5. Watch Pi boot up to the Volumio black screen and freeze there
  6. Wait a couple hours: nothing happens still and no network connection or hotspot.

Additional Information

This is a new Pi and it works because PiOS and Ubuntu and RetroPie and other images boot on it. But Volumio consistently freezes at boot. I tried two different SD cards, I am using the official 15W USB-C power supply.

Had the same issue last week. My problem was the used SD. Took a new one and it worked.

I tried with different cards, and all these cards with Pi OS or Ubuntu work. I also tried a few USB keys and they work with Pi OS/Ubuntu but not Volumio.

Can you attach a monitor to your pi, are there errors?

I have, and there is nothing at all. It shows the rainbow, then a black screen with the Volumio logo and that’s it. I can’t do anything (keyboard/mouse unresponsive), it doesn’t acquire a network address (doesn’t even request one according to the DHCP server logs), it just stays there crashed for ever. I even let it run overnight just to see and in the morning it was still on the same screen with the Pi 4 super hot.

Did you follow the Quick Guide?
Volumio initially starts up headless (no display).

Are you sure, die to the rainbow, that your PSU is powerful enough?

And did the verify part of etcher completed without any errors?

I have. It doesn’t even start Volumio, it crashes as soon as the black background with the volumio logo appears. So it never requests a DHCP lease on ethernet, doesn’t create a hotspot, doesn’t expand the partition, nothing. I let it run for a few hours just in case and all it did was get hot but nothing happened. The green activity LED also turns off once it crashes.

It’s the Pi’s official 15W USB-C PSU. It works fine with PI OS in 4k or with LE10 in 4k.

Yes, no errors.

last suggestion, as I am running out of ideas.
Have you attached something to the USB ports, if yes remove everything. just boot the rPi with a fresh image and wait for 5-10 minutes with nothing attached.

If you already did that, I have no clue…

Already done that :confused:

try a 3.xx version maybe that works…

I have the same problem and I had tried version 3.xx and still not working. Anyone found the solution?

what is your set-up and what did you have installed…
and with what did you burn your image.

you know you have to unzip it before burning?

I used rpi4b 2gb with 15w power and burn the newest version 2.882 into my sd card using balena etcher.
I connect it to the power and it seems to boot fine, but after that my screen just show blank(black).
yes I unzip it.

blank not some text? like login?
volumio you could see in any browser in your network …
try http://volumio.local or ip of the pi . (beware volumio doesn’t use https:// so use http:// )
wifi you can set-up if your in volumio…
hook it up wired first … if you want to discover your ip
you can login ( in black screen) and use name :volumio pass: volumio
type: ip address and hit enter
inet will give you your ip

After those text.
no there isn’t any wifi named volume, and I tried to connect it with ethernet, and it still not show up
I’ve search devices from my router, no appear

I put there few hours and I just saw the wifi…thanks for help