No sound with version 2.285


I have a Hifiberry DAC + and since my last update to 2.285 there is no sound and no startup sound. I did several restarts with no result. Maybe there is someone with a suggestion?

Disable i2s dac, save and reboot, then enable i2s dac, select hifiberry dac+ and save

let us know

Same issue here with hifiberry plus. After OTA update I had no sound. If I choose output the “Allo Boss” my hifiberry plus works again. I than did a fresh install and experience the same issue. hifiberry works only if output setting is set to All Boss…

Same thing for me. Raspberry Pi 3, IQAudio DAC+. Did a OTA update, no sound since. Deactivated I2S, saved, rebooted, reenabled.

No obvious errors in the Volumio log file.

Output of aplay -l is:

volumio@iqaudio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: IQaudIODAC [IQaudIODAC], device 0: IQaudIO DAC HiFi pcm512x-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Can you check if the IQAudio is muted via alsamixer?

Having same problem - this worked for me.

Thanks Michelangelo, sound has returned! The green LED is visible now only when sound is transmitted, which was not the case after the update.

Thanks for sharing. Works like a charm!


I enabled/disabled i2s and switched output devise several times. Now it works :slight_smile:

Auto Mute in Alsamixer is set at 0, which I believe means it is off. But I did a couple more reboots and I am now getting sound of the left channel, but none out of the right. I have another source for my preamp and it’s fine, so this is odd. I’ll plug a different software image into the Rpi to try to diagnose it further.

Thanks, please let me know

Same problem with OTA update on Allo DigiOne. Solution suggested works. Switching off i2s, reboot, switch i2s back on And choose Allo DigiOne, reboot, works.

Not sure about this, but a factory reset seems to roll back the OTA update. Got prompted to update to the latest version again (same version and change notes as before) after a factory reset.

Sent from my SM-N9005 using Tapatalk

Upgraded to 2.295, same problem. After diving deeper, the problem turned out to be the right speaker cable had pulled out of the Raspberry Pi. Working perfectly now. :slight_smile:

I have a similar issue … upgrade yesterday, No Sound since upgrade.
RPi 3, HiFiBerry DAC+ upgraded to 2.285
Have done the disable i2s, save, reboot, enable, save, reboot … no success.
Any log information of value, or any more suggestions?

gads … after i post, i save and reboot again … all working now!
Murphy is always right.