No sound out of HiFi Berry DAC + with Volumio2 (2.799)

when i try to enable IS2 and chose my DAC from the list and restart i get a error message (Failed to open “alsa” [alsa]; Failed to open ALSA device “hw:2,0”: No such file or directory" when i do play a song but when i select the DAC from the output device list it plays audio

could someone point in the right direction to fix this problem


Hifiberry Dac +
Volumio 2 (2.799)
Raspberry Pi 3B+

1 Like

Had the same problem

Change Output to headphone , save and test
Change Output to HifiBerry +, save and test
(may be a reboot in between)

Can you guys please send some logs?

The lastest image has a new kernel and a new audio handling numbering. We tested carefully but it seems this requires to:

  • Save audio configuration
  • Reboot (possibiliy removing power and reapplying)

I’m having a similar problem. Updated to 2.799
I get the following errors.

“alsa” [alsa]; Failed to open ALSA device “hw:2,0”: No such file or directory" and no sound.

Pi 4,
Hifi berry amp 2

I tried your solution rebooting and powering of at each step. .
Output to head Headphones - system works as expected.
Output to HiFi Berry Dac Plus - ALSA errors and no sound with spotify.

Is there a new update coming?


same proble for me:“alsa” [alsa]; Failed to open ALSA device “hw:2,0”: No such file or directory" and no sound. Using generic I2S with fifopi

please fix this bug or revert to previous state!

1 Like

Hi guys, I just read this topic, + 1 from me. I reverted to the old version for now.

How do you revert to the previous version? I got no music!


I flashed an SD card with the old version and did not update.

OK, this is quite weird. I got sound on the new version, what SonosKiller writes is actually correct.
Change to headphones, save.
Change to your DAC but DO NOT click the I2S dac, it is on off but it works?!

and it looses configuration after reboot :frowning:

Super strange.
I need you guys to provide some info, so we can debug it and fix it for good:

  1. Send the log see:
    Paste the log link into the reply
  2. Paste the output of the following commands (enable SSH first)

aplay -l
cat /boot/config.txt
cat /boot/cmdline.txt

Providing this info will help troubleshooting. Those regressions are resulting from a kernel update (the latest stable from Raspberry PI foundation). Using previous kernels is not an option moving forward…
Thanks for the help

you should have received the log?
I will run the commands now.

This is while the ES9038PRO dac is playing:
card 0: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 1: ApplePiDAC [ApplePi-DAC], device 0: bcm2835-i2s-pcm1794a-hifi pcm1794a-codec-0 [bcm2835-i2s-pcm1794a-hifi pcm1794a-codec-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

initramfs volumio.initrd

include userconfig.txt

Touch Display gpu_mem setting below: do not alter


same problem here with Raspberry 3b+, audiophonics digipi+ pro DAC, coaxial output, Volumio 2.799. ALSA errors and no sound with spotify and webradios. I disable i2s dac, reboot, enable i2s dac again, but the problem still exists

Just got everything put together with my up-cycled vintage radio with Raspberry Pi 3B+, HiFiBerry Amp2 (DAC+) and Volumio. All was working fine until I upgraded Volumio to 2.799. Now, same problem as others on here. No sound with any audio source (network share, Spotify, web radios). Tried some of the suggestions above, still no sound. I have sent logs per the instructions (

Is there someplace to download the image for the previous version?

Can we get an update from the volumio team? The new version is useless.
I tried alot of things, but after a reboot no sound. Need redo the procedure and it works until next reboot.

Older volumio versions .img files

Same here - almost identical setup.


Going to roll back for now,


I have the same problem. But only if I add the touchscreen into the mix. What seems to happen then is that the card1 (HDMI) disappears from aplay -l. Volumio still tries to address card2 (hifiberry) which now is card1, giving me the ALSA error. Forcing card1 via mpd.conf will work but the mixer is then set to “undefined” so no volume control.

Removing the touchscreen and setting up the Hifiberry Dac+ will restore sound, as the HDMI returns as card1.
Do you guys have the same problem? I see only two devices in your aplay -l-logs.

Question: Is there a way to change the order of the soundcards, so Hifiberry is 0? Or maybe could volumio recognize HDMI is missing and update the order of the cards?