No cover art even with local jpeg

After scanning my music library, I noticed some of the album cover art were not downloaded from the internet. So I placed a cover.jpg in the same directory of those albums. After rescanning, those albums are still showing no cover art. Renamed the file to Cover.jpg, folder.jpg, Folder.jpg with no effect. Did rm -fr /data/albumart/ and rescan. Still no avail. Is this a known issue in the current release?

Hello,
Check if clearing the browser’s history helps (clearing the cache of all images and files downloaded). It helped me. Rescan was not enough and not even the rm command.

I use the file name cover.jpg

Best regards, CB

Hi,
Thanks for your pointers. I tried clearing the browser cache today, but it still didn’t work. I am also using the name cover.jpg. Can you be sure, the album art you are seeing is from your local file, and not downloaded from the web (if you turn off web download, does it still show the art)?

Best wishes.

See

https://volumio.org/forum/album-cover-art-t4953.html

Yes, I can confirm that I can locally change cover images.

  1. I saved a new random image in the subfolder and named it Folder.jpg this time. Moved the old image elsewhere. Did the rm command on the Raspberry, cleared the cache in the Google Chrome web browser and did a Rescan of the Music Library. The new image showed up in the Queue tab and Playback tab as expected.
  2. I removed the new image. Did a Rescan, cleared the cache and the rm command and then I got the default image, which is correct. The (test) track in the subfolder had no tag information. (which meant that the album cannot be retrieved from Artist or Album view).
  3. Put the new image back again (Folder.jpg) and added the correct tag information to the track. Then I could retrieve the track from the Album/Artist view with the new image Folder.jpg. However it did not show up after the usual procedures as above
    . . .but when I did a remount of the file share then it showed up in the Album/Artist view as well, that seemed to do the trick. A little bit tedious, might be a bug???

[Addition: now I discovered that I cannot retrieve the album by browsing the Album view, only by using the Search function (which I always use), that was odd. Something is not right. I use 2.141 and it looks like there have been a fix in 2.163, I will upgrade soon to 2.175.]

Best regards, CB

Hi CB,
Thank you very much for your detailed description. For me, strange things are happening. When I follow your steps, sometimes the local file is displayed in the playback view, but not in the album view. Sometimes, none of the views displays anything. I found a workaround which I posted here: https://volumio.org/forum/#p32979 For now, this works for me.