New Volumio Virtuoso user (HifiBerry DAC2 HD) - no sound

Hi,

I thought I’d try Volumio for Spotify and Qobuz. I have it installed on a Pi4 and using a HifiBerry DAC2 HD (which was recognised straight away). Installed the Spotify plugins and logged into Qobuz. Volume turned up. Nothing playing. The UI tells me something is playing but no sound. Also within the Spotify app my Volumio rasp pi is seen but cannot connect. What’s going on?!

what version are you using?
is this above Linux kernel of at least version 4.19.97 ?
if yes is this in your config.txt :
dtoverlay=hifiberry-dacplushd

Well I downloaded it today, so would assume it must be the latest version no?

there are many versions that people could use and download so i can’t see
but i checked it in log :
2.799 (16-07-2020) 4.19.118 Kernel for Raspberry PI should be oke

can you check in /boot/config.txt if the “dtoverlay=hifiberry-dacplushd” is pressent.

How would I do that? Take the microSD out of the Pi and back into my Mac?

Sorry this is all a bit new to me! And thanks for trying to help!

no you could ssh in to your pi … but you have to enable it first in the pi
use your ip /dev or volumio.local/dev to enable ssh in the pi …
if you have a pc by the hand would be nice i know it on the pc
for the mac it’s more search and guess work for me…

so I clicked on enable SSH and not much seemed to happen but I did click “enable”

no PC I’m afraid…

ahh and if I click live log then is says SSH enable success

how would I now look at config.txt

with putty you could ssh in to your system

sorry I don’t actually know what putty or ssh mean…

ssh is a way to talk to your pi from your mac putty or sftp/ftp client logs in to your pi
there you could edit or do file transfer… or install things ect…
but we can check first if the pi is set to the right device …
go to settings >>> playback options and say wath you have standing by outputdevice …

that doesn’t really make sense to me either… like I can understand each word but put together in that order they don’t make sense to me…

if I have enable ssh then what would I have to do?

we skip the ssh part for now
gonna try it first with the settings in volumio

but we can check first if the pi is set to the right device …
go to settings >>> playback options and say wath you have standing by outputdevice …

yes my audio output is set to:
IS2 DAC enabled
DAC model - HiFiBerry DAC 2 HD

that should be oke , back to the ssh :slight_smile: i will look if i can see the files of my system on the pc
i don’t know what partition is visable with putting it straight in the pc i use always ssh …

i checked you could find the config.txt if you put it in your mac and goto boot partition you will find it there

add this before the last line of text:

dtoverlay=hifiberry-dacplushd

and save it put it back in your rpi and boot…

as in if I just put the sd card in my Mac?

yess :)P the file is in boot partition …

found it I think:

initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1

include userconfig.txt

Volumio i2s setting below: do not alter

dtoverlay=hifiberry-dacplushd

it’s set as it had to be i followed the steps i know and all seem to be oke…
let see if some one else knows more this should work … more i could not find by hifiberry