New Volumio Spotify Plugin Open Beta-Testing

I have a question. With this new spotify plug-in, after we write credentials, are we supposed to see the spotify icon and/or spotify menu on the side like we normally do, or it is now something different?
My problem is, i can not see spotify anywhere on volumio screen both rp3 and webpage (volumio.local)

I have tried the update and it works fine, but today it had an unwanted behavior, some tracks quickly go to the next one and for the last time the playback stopped.
If the playlist could load more than 200 songs it would be great, even if it was in the premium version.

Model: Raspberry Pi 3
Volumio: 3.198 (Free)
Wired Connection
Spotify Familiar Account


Ja, dat is al vaker gemeld.

Please post in English as not everybody speak Spanish.
Seems a bug, as many people have reported this.
it’s still in a beta release.

just for sake of completeness - I still have this error ("[Vollibrespot] : SessionError: Connection reset by peer (os error 104)" - see Handle reconnection for Sessions · Issue #134 · librespot-org/librespot · GitHub) after 2-10 songs or so. Not a specific error of this plugin but a general one in my network with RapsberryPie+librespot (same on moode or with the old version of volspotconnect).
I used to love volumio as it was the only software offering a “built-in” solution, which didnt base on librespot and just worked. Guess it’s over now :frowning:

Same problem with my Raspi4. Switch all the playlist , read nothing, juste switch .

Dac Hifberry HD pro
Volumio premium V3.301
Spotify premium

1 Like

Updated Spotify plugin works for Me without any issue. Incl. Bitrate info. Thank you

Rpi4, Volumio 3.129. JUST BOOM DAT HAT. Spotify Premium

1 Like

Thanks Michelangelo, the plugin is works beautifully.

I comment is if you don’t reboot after installing and setting up the new plugin, the first time you start a spotify playlist, it jumps from one track to the next. The happened on two my devices, and a reboot fixed it.

Running volumio 3.251 (free) on rpi3 + Iqaudio , wired and wireless connection. Spotify Family Account

New Plugin works like a charm for me… no issues what so ever…

Volume version 3.301 Payed . On raspberry pi 4 with Allo Boss DAC.

Thank you very much to all contributors for this super quick fix… ))

I do advise to restart the player after installing the new plugin and after login to Spotify… ))

I am having an issue when playing using a playlist , the system will randomly jump to next song or several songs forward.
pi 4 with latest volumio installed

Plug-in working great for me. Thanks so much for the quick turn around! Using the Spotify app to start/stop play and browse.

Rpi 4b
Volumio version 3.301
USB output to zdac
Free myvolumio account
Premium Spotify

1 Like

Rpi 3b+ with Audiophonics RaspDAC Mini
Volumio version 3.301
Payed Volumio account
Premium Spotify

Plugin works as expected, except for the already mentioned ‘random’ progression when selecting next track in a playlist. Btw, this also happens in other services, like Qobuz.

Thanks for the great work, Volumio team!

Same. Playback HAS to be initialized from Volumio in order for it to appear in the Spotify app. But after a while it disappears again from the app.

And when it is appearing at all, it looks like a projector.

Yep. If you start Spotify playback from within Volumio, THEN you can see it in your mobile Spotify app. But eventually it disappears again.

Just installed on my Integro, so far so good! it works like a charm!

Trying this on a fresh install pi zero w and no other plugins installed. Walked through the initial setup and tried to install the plugin.
Where I get stuck in the process is this line: “Status :Downloading plugin
nloading plugin at
And logs show this:
Jun 19 16:03:53 pirateaudio sudo[1005]: volumio : TTY=pts/1 ; PWD=/home/volumio/volumio-plugins-sources/spotify ; USER=root ; COMMAND=/usr/local/bin/volumio plugin install
Jun 19 16:03:53 pirateaudio sudo[1005]: pam_unix(sudo:session): session opened for user root by volumio(uid=0)
Jun 19 16:04:03 pirateaudio volumio[884]: …++++
Jun 19 16:04:03 pirateaudio volumio[884]: e is 65537 (0x010001)
Jun 19 16:04:03 pirateaudio volumio[884]: writing RSA key
Jun 19 16:06:06 pirateaudio volumio[689]: verbose: New Connection to from UA: node-XMLHttpRequest Total Clients: 5
Jun 19 16:06:07 pirateaudio volumio[689]: verbose: New Connection to from UA: node-XMLHttpRequest Total Clients: 6
Jun 19 16:06:08 pirateaudio volumio[689]: info: Downloading plugin at
Jun 19 16:06:08 pirateaudio volumio[689]: info: Cannot download file - Error: Command failed: /bin/mv /tmp/plugins/ /tmp/
Jun 19 16:06:08 pirateaudio volumio[689]: /bin/mv: cannot move ‘/tmp/plugins/’ to ‘/tmp/’: Permission denied
Jun 19 16:06:08 pirateaudio volumio[689]: info: Error: Error: Error: Command failed: /bin/mv /tmp/plugins/ /tmp/
Jun 19 16:06:08 pirateaudio volumio[689]: /bin/mv: cannot move ‘/tmp/plugins/’ to ‘/tmp/’: Permission denied
[1]+ Stopped sudo journalctl -f

I tried to take ownership with “sudo chmod 0777 /tmp” but no luck.

1 Like

This a thread for Spotify…Why do you install pirateaudio (you said no other plugin…)?
did you modified volumio password?

Pirateaudio is the hostname that I have the player set to because I do have the hat attached(Pirateaudio.local). Password is still default.
Edit: Out of curiosity I changed the hostname back to the default of volumio, rebooted, and ran into the same issue.

can we make it to load on the volumio queue more than 100 songs from the spotify playlist?

Asus Tinkerboard
Topping D50s usb DAC
Wired LAN
Volumio Free
Spotify Premium Family

The Spotify track does not start playing.

Live log:
info: CorePlayQueue::getTrack 42
info: CoreStateMachine::startPlaybackTimer
info: CorePlayQueue::getTrack 42
info: [1655668807241] ControllerSpotify::clearAddPlayTrack
info: Setting this device active
info: Failed to Set Device Active: Error: Not Found

When I try to seek:
“Spotify Connect API Error.
Not Found”
Live Log:
info: CoreCommandRouter::volumioSeek
info: CoreStateMachine::seek
info: CorePlayQueue::getTrack 42
info: TRACKBLOCK {“uri”:“spotify:track:4PqVvCR2pHNhxlFGVVMuAy”,“service”:“spop”,“name”:“The Desert Rocks”,“artist”:“Chris Huelsbeck”,“album”:“Turrican Soundtrack Anthology, Vol. 2”,“type”:“song”,“duration”:237,“albumart”:“",“samplerate”:"320 kbps”,“bitdepth”:“16 bit”,“bitrate”:"",“trackType”:“spotify”}
info: CoreStateMachine::startPlaybackTimer
info: CorePlayQueue::getTrack 42
info: Spotify seek to: 187000
info: CoreStateMachine::pushState
info: CorePlayQueue::getTrack 42
info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
info: CoreCommandRouter::volumioPushState
[SpotifyConnect] Not Found

Hi @stooovie,
I get the same issues like you - do have actually a solutions for using the phone app using the spotify connect capability?

Br, Thomas