Music Library empty after reboot - Raspberry Pi + Volumio

When I connect an USB memory stick (128 GB ARCANITE) to my Raspberry Pi (Volumio 2.729 18/03/2020), quickly start the library update and after a while all the music titles are ready to be played.
If I leave the USB memory stick into the plug and I reboot the system, the music library is empty again! Furthermore, if I try to play anything else, for example a WEB Radio, the music doesn’t start.
I’ve to force a library update and then,only after the update has been finished, I can play something by the USB memory or some web radio.

I’ve already tryed with a fresh install, but I’m getting the same result.
Wondering if the problem could be related to the file system format of the USB drive (NTFS), I’ve tryed with another USB stick in FAT format, but the result is the same. The issue is still unresolved…

Is there any workaround to solve this issue?

Thanks a lot.
Regards
Antonio

Had a similar issue with NAS that was empty after a reboot.
Found a workaround, but first lets do quick test to see if it is indeed a similar problem…

If you have an empty library after reboot…what happens if you press “settings–> Playback Options–>Audio Output --> Save”?
Does the library reappear?

Yes, it works : when I click the SAVE button after a ten of seconds appears on top right of the window the message : “Configuration updated, the player has been restarted”, volumio-player-restarted.png but I have to repeat that operation at every boot, because after the first time, at the next boot, the library seems ok, but I can’t start playing anything…
Is there a way to execute automatically that command (or another with the same result) via a bash script at boot?

Thanks a lot.
Antonio

Do you have by accident an RPi4 ? The problem started for me after I migrated from an RPi2 to an RPi4.

I was able to find a working ‘workaround’ (see below), but not yet a final solution.
Maybe this is something that Michelangelo could share some light on?

I noticed that:
Sometimes it boots OK and my NAS content is visible. But most of the time it is not.

  • NAS visible after boot --> mpd process runs as user ‘mpd’
  • NAS not visible after boot --> mpd process runs as user ‘root’
  • After manually restarting MPD (sudo systemctl restart mpd) --> mpd process runs as user ‘mpd’ --> NAS visible

My 'workaround’solution;
I changed; /etc/systemd/system/multi-user.target.wants/mpd.service, by adding a 60 seconds startup delay for mpd.
After delaying the startup of mpd: mpd is always running as user ‘mpd’ upon reboot and the NAS is always shown in the music library.
So there are clearly some ‘timing issues / race conditions’ in the startup of Volumio that becomes noticable on a RPI4.

[Service]
Type=notify
ExecStartPre=/bin/sleep 60
ExecStart=/usr/bin/mpd --no-daemon

But this is more a ‘workaround’ then a proper root cause solution

Adding the 60 seconds delay to mpd service start, it works.
No, the hardware is a Raspberry Pi Model B Plus Rev 1.2 512MB.

Yes, maybe Michelangelo could analyze the issue to fix in a next release.

Thanks a lot.
Antonio