Multiroom sync volumio 3 not working

Hi team,

My 3 raspberry’s are on the latest 3.233 and everything is working fine.

Today I tried the multiroom sync but somehow I am unable to get it in sync.
I changed the latency on the client (using only 2 raspebrry’s to start) but it seems nothing is changing whatever latency I am selecting (from 1 to 1000).

What am I am doing wrong. I already surfed the internet for solutions but could not find any solution.

Could somebody help me adjusting the client. Thanks!


What do you mean exactly?
That the audio is not synchronized perfectly? Do you hear some latency?

Let us know in more specific ways, also what kind of audio card you use

I hear some latency what is of course normal. Two different setups.

One rasp3b+ is connected via fifopiQ2, reclocker to a TDA1541a DAC, the other raspb3B+ has a Dionaudio-loco-amp-v2 hat on it.

Music is send from the main raspb (connected toTDA1541A dac) and music is sounding via the other raspb (Dionaudio hat). That is working perfect.

Music from the raspb with Dionaudio hat is faster and just a moment later you hear it from the other raspb via the tda154a dac.

I don’t know at which raspb I have to set the latency to get it in sync.


It is for sure the FifoPI: reclockers usually introduce some latency (some even 0,5 seconds). So to get it perfectly in sync, you shall find out how much latency fifopi introduces, and set this value in the fifopi device.

Let us know

Thanks for the reply.

I will let you know if I get it done.

is the latency in ms?


Whatever I tried, I don’t get the FiFopi device in sync.
I tried values from 1 to 900 to check if something is changing but the latency stays the same.

Also tried reverse with the other raspb, also the same result. Nothing changes the latency.


Would be nice if somebody could check this issue.


We noticed that the settings sometimes require a reboot to take effect.
Can you try that and let us know?

Both devices rebooted. Same result.
Is it possible that latency is set not in the i2s domain and therefore not working with fifo and reclockpi?


@advr61 Did you solve this?

I’ve got a RPi 3B+ with a JustBoom DAC HAT connected via ethernet and an old RPi B with a HiFi Berry DAC connected to WiFi and the RPi B seems to be ahead. If I add a delay to the RPi 3 (acting as a server) it seems to not play at all on either client and crashes the RPi B.

Not sure if it’s related but changing either buffer in Mulitroom Configuration > Server Configuration, doesn’t save either.

The issue is still not solved. Hope the developer has some time to investigate these days.

I have always sound on both devices, whatever I do.
Probably this is some other problem or just coincidence. Can’t help you :frowning: Sorry.