Mixer Type keeps resetting

Hello,

I have just set up Volumio and leave it running 24/7 on a Pi4, with a Topping E30 via USB, I set my Mixer Type to ‘None’ as I have a pre-amp to control the volume. But when I turn the DAC off and back on, the mixer type resets to ‘Hardware’ every time. Is their anyway to have it stay as ‘None’ without having to keep the DAC on 24/7 as well?

I have a feeling this keeps resetting, as the DAC is ‘disconnected’ and ‘reconnects’ to volumio, which picks it up as a new device every time? (I’m assuming here) And that defaults it to ‘Hardware’ Mixer type.

2 Likes

I think your feeling is correct, but how you make it persistent ?? Sorry, for not having ideas … surprised actually that I’ve not seen this problem reported previously. Did you do a forum search?

Could it not be stored as a permanent value in the settings/config perhaps??
I have tried searching around, but not found any mentions of this issue, I’m assuming most people stick with ‘Hardware’ as their Mixer Type

Update: I’ve tried setting it manually to ‘none’ in the mpb config and the template, but it still seems to be overridden to ‘hardware’ when the DAC is turned off and on.

Volumio 3.175 also has this problem. I would prefer to have mixer type NONE, because otherwise Spotify connect won’t work with my ASUS XONAR ESSENCE STU -USB DAC & Raspberry PI 4B

Hi, does the same thing with my McIntosh C49 DAC on 3.179. I believe this has to do with a feature where volumio detects whether the DAC has hardware mixing and enables it for you. It’d be nice if you could configure and turn this feature off by DAC.

1 Like

Same for Pro-ject Pre Box S2 Digital.
Never noticed before, but needed to disconnect my DAC for a different topic and had a hard time getting the DAC up and running again.

I happened upon this thread after I also hit this issue and thought I would share what I did to fix it. Perhaps Volumio saves its device state somewhere but I couldn’t find it after a little bit of sleuthing. This is what I did:

Add ignoreGenMixers = carddata.cards[n].ignoregenmixers this line and add my own device entry to this file. In my case my entry looks like this {"name": "DENAFRIPS USB Audio V3.12", "multidevice": false, "prettyname": "Denafrips Ares II", "defaultmixer": "", "ignoregenmixers": true}. Just make sure you get the name correct, it needs to match your device.

1 Like

Thanks guys for the report.

Yes, this is a bug. We assume that you are configuring your DAC for the first time, so we select the best mixer automatically.
Added to our bug list, but this is very very low priority, so not sure if\when this will get addressed

1 Like

Hi Volumio team,

Sorry but how can this be a “very very low priority” ?
While I love your software, it’s absolutely ruining the experience to have to go in the settings every time I restart my dac(s) to set the mixer to none so I can listen to music.
Worst, it’s definitely not family friendly …
Any temporary solution we can apply to make the setting permanent until the patch is delivered ?

4 Likes