lsusb cannot find IDE/SATA adapter (cannot find /dev/sda)

Hi World, really hope someone could resolve my problem.

I have build a Suptronic X4000k, base one a Pi3, add on a ES9018k2M DAC and a usb harddisk. It is a nice little kit for good sound quality player.

However, I run into a trouble that sudden the harddisk disappear today. The strange thing is, if I run Moode, it can see and recognize the harddisk without a issue. If I run Volumio it iust cannot recognize it.

I login to SSH, type lsusb , in Moode, it shows “Gensys Logic, Inc. IDE/SATA Adapter”, in Volumio, it is just missing this device.

So, I think this is driver issue. I try to use this sudo apt-get update then sudo apte-get dist-upgrade After that, using SSH, :bulb: sudo fdisk -l . I can see the dev/sda is back.

However, Volumio cannot run, because I update Debian distribute. :imp: :imp:

I am no good in linux command, all above code, just find it from different forum when I search for answer. But, I cannot find any more good hints to resolve it. Can anyone help me on this?

Thank you!

To find out what volumio thinks is going on, do the following steps:-

  1. login to volumio
  2. disconnect the USB device
  3. run sudo tail -f /var/log/volumio.log (or kern.log)
  4. connect the USB device and watch the output

From this you should see what’s going on. I’ve listed kern.log up there too, but that’s only necessary if volumio.log doesn’t show anything useful.

Hope that helps.

N1md4, thanks for your advice.
I actually resolve it. I have tried to reinstall volumio to the sdcard, but still can’t recognize the Hard-disk. Then, I go to system and try the reset factory setting. Haha! It’s work.

Don’t understand, why restore volumio IMG to sdcard, that don’t work, but it works with the reset factory setting, I thought restore the image, isn’t it same as reset everything…

Anyway, reset to factory setting resolved this issue.