Large library scanning limit?

Hi, I’m running volumio 2.852 on raspberryPi 3B+ with HifiBerry Digi and library on 1tb SSD and 500gb USB.
All was working fine (adding files over network was a bit faffy but I could live with it) I even had access to both USB sources through the library (I never used artist, album or genre it took to long to load and I’m fine with my folder structure) at some point It stopped adding new albums, and would scan half of one drive, then forget it existed and start scanning the other which it would never get through.
I’ve done lots of re-flashing, given up on one of the drives for now, tried format the SSD to FAT32, tried a 64gb sd card (usually 32gb) and even tried a different Pi3.

It scans up to about 3000 artists and either forgets the drive exists or starts scanning again, never to complete.

I really want to fix this as I really like volumio, I’m happy to subscribe to a plan but I don’t require any of the features it offers.
I’ve moved over to Rune for now as that scans all files but it’s no way near as good as Volumio (on a number of levels)

I’m very green with raspberry pi and computer lingo but happy to learn.
Hope someone can help


This topic comes up pretty often, a few things to check out

  1. Make sure you only have audio files and the cover jpg, video files etc make volumio bail on the scan

  2. Download foobar2000 (it’s free) scan your audio directory, sort by track length and remove all zero time tracks - again these seem to make volumio have issues

  3. If the above don’t work, search this board for similar peoples requests for help and see if there’s one I’ve missed

1 Like

I faced a simmilar Problem. The reason was: defective Files. Solution: Take a Tool like Foobar2000, put all files in a list and sort the list for playtime, I’m pretty sure you`ll find some that have a pliaytime of 0 seconds or even no playttime -> remove this files. Another reason may be unsupported Formats, like AVI, MP4… After the Foobar2000 action please perform this: Open The Drive in Windows Explorer. Type *. in the search box -> This will listt EVERY file on this drive, sort tthe results by Type and size. Then remove every “non-audio” media format like mkv, avi, mp4… (except pictures/covers) Then also have a look at the filesize, if a file is smaller than a few KB MPD sometimes haves a problem with them.
After tthe above steps, rescan the Drive with volumio.

Good Luck

Done all that : no progress.
It is a recurring problem.
Notice : I have one more tag : “work” (classics users will understand why).
I DO NOTwant to delete it only to see if Volumio works. Anyway I would not agree…

If it were a tagging problem it should already have been solved.
I do not understand that nobody has found a solution of this old problem.

Developpers here ???

I abandon using Volumio with an HDD.
My raspi works perfectly, only as a DLNA component, e.g. on Foobar.

All sorted, thanks for the heads up on the few things I could look out for.

I deleted zero time and any non music files but the problem still persisted.

I eventually sussed it by monitoring the scan and at what point it crashed/started over deleting that folder.
I haven’t had time to troubleshoot the folder in question (it had a group of albums so could be any) but I did see an older post about imbedded artwork and I’m just going to assume it was something to do with this.
The post did say they figured out the problem with a journal command (or something) but as I’ve never used ssh or command stuff the prospect was a bit daunting.

Glad it’s working for now but any advice on troubleshooting (should this happen again) would be welcome.