Just one Album not showing its artwork

Volumio Information

Volumio Version: 2.834
Hardware: Raspberry Pi 3 Model B Rev 1.2
DAC: Adafruit UDA1334A into TV sound bar via analogue cable

I have a very odd issue that has me a bit baffled. I have just ONE album that refuses to show any artwork during browse and only shows the ‘Volumio’ picture:

Screenshot 2020-12-19 at 13.26.52

The album has a valid JPG file and the image is in each track:

I’ve tried a sources rescan and update, even tried a reboot but all to no avail.

The tracks and folder are on a USB hard drive and I’ve checked file / folder rights and they match other albums:

-rw-r--r-- 1 volumio volumio 25997277 Dec 19 12:25 01 Come And Let Me Look In Your Eyes.m4a
... (tracks cut for brevity)
-rw-r--r-- 1 volumio volumio 28391618 Dec 19 12:27 17 Golden Slumbers _ Sweet Sweet Life _ Tremble If You Must.m4a
-rw-r--r-- 1 volumio volumio   278056 Dec 19 12:30 Folder.jpg

The image is not that large (1500x1550 pixels) but views fine on the Mac in ‘Get info’ and Preview modes (as well as Finder as above).

Anybody any thoughts as too how I get the artwork to show?

I had something like this happen. Check image file size is under 1 MB.
If that’s not the issue continue as I did. I figured out it must be a corrupt image file or something else odd, (it displayed fine on my PC and I could open and save it in Photoshop).
I deleted the whole album from Volumio (from the USB drive).
Restarted Volumio and made it rescan the music database and also refresh/rescan the image cache.
Then I made a fresh album art image and saved it at the correct size and filename.
Then I added the album back including the fresh folder.jpg.
Then I again updated the music database and finally I got it to display the album art correctly.

Thank you for your fix and please forgive the delay - health limits what I feel up to and this came low on the list :sob:

Sorry to say no luck. Tried both rebuild and refresh but zero change.

Entry in the database goes when I delete the folder and rescan fine.
It does not show up while browsing post replacement (but pre-rescan)
It does show up again but still with the wrong image post rescan.

Image size is well well under others on the box. For example, my Eva Cassidy image is 2.1Mb at 1665 x 1429 pixels, 300 pixels per inch whereas this is only 278Kb at 1500x1550 pixels 72 pixels per inch.

Checking all file / folder rights gives a very odd mix compared to the others:

drwxrwxrwx 3 volumio volumio 4096 Jan 14 19:49 Spirit
drwxrwxrwx 2 volumio volumio 4096 Jan 14 19:51 1

-rwxr-xr-x 1 volumio volumio 25997277 Jan 14 19:50 01 Come And Let Me Look In Your Eyes.m4a
... (tracks cut again)
-rwxr-xr-x 1 volumio volumio   278056 Jan 14 19:50 Folder.jpg

I’ll set these to match the other folders e.g.:

drwxr-sr-x 3 volumio volumio 4096 Apr  3  2020 Sunshine on My Shoulders
drwxr-sr-x 2 volumio volumio 4096 Apr  3  2020 1

-rw-r--r-- 1 volumio volumio 28028493 Apr  3  2020 01 - John Denver - Sunshine on My Shoulders.m4a
... (tracks cut again)
-rw-r--r-- 1 volumio volumio    25772 Apr  3  2020 Folder.jpg

and do a rebuild again.

I think something is a bit odd with the USB share so I’m not convinced this build is 100% - I can only make copies / changes through ssh (e.g. getting the file back after the rm took scp -r andrew@andrews-mac.local:/Users/andrew/Desktop/Spirit .) and not the Mac Finder despite the Mac reporting I have all rights and the smb share being defined as:

        comment = Lr-music USB Music Folder
        path = /mnt/USB
        read only = no
        guest ok = yes

After that is to redo the image scan to match the others (not sure why this scan was 72 dpi) but I think the disk in now tucked away! One test option is moving this all on to an internal SD card but cannot find a large enough one tonight :frowning:

Changing the security rights had zero effect.
Changing the DPI on the image had zero effect.

Tried two on-line editors (just if it was just my machines being happy) and they where fine with the image (so it does not look like it’s corrupt).

No large SD card in the house not being used in live machines / cameras so may knock up a NAS and try that rather than spend some money this month as I have a spare drive…

Very very odd.

I decided to create a new SD card with the latest version (2.861) on it and try that first (as I really do not want to copy over 100Gb of music to a new drive across the wifi) and the result is almost OK :flushed:

The Spirit album cover shows fine (No changes to the source drive - only the OS image SD card)

Now the odd things are:

  • First catalog stopped part way through (200+ artists rather than the 550+ I have) but the second using the ‘rebuild’ function completed.
  • Build went fine except it did not respond by name (only IP) till I turned off the in-built AP function and did yet another reboot.
  • The old version reported that I could not make a folder under the Volumio users home directory - reporting disk full. That seems to have cleared on this copy ?!?!?
  • I still do not have the ability to copy music / folders via Finder !?!?!
  • I now have TWO devices on the network (music and music.local) despite the old machine being lr-music.local and the new one being music.local
  • Some of the artists are now split despite the meta-data being the same across the album - these where not split before !?!?!

It’s possible the SD card is a bit ‘up the creak’ with the write error showing up (we do get power cuts here) - that’s next to look at.

So in summary - my initial problem has gone away but multiple NEW ones are now present arrrgggggghhhhhh.

Possibly corrupt music or image file/s messing up the scan and cataloging.
It’s frustrating chasing some of these odd problems

Look for things like different case on album names, and vs &, etc.

The old SD card has re-imaged fine so its not ‘write protected’ unless the wear levelling has kicked in on the user directory structure.

The hard disk itself checks out fine (at sector and file system levels) so I think its either the original disk format (was formatted on a Mac using extFS for Mac) or something in the share set-up that’s stopping me writing.

I’m unable to explain why the index would stop part way first time then continue if it was a data driven error - that does not seem to make any sense to my poor old brain… Next set-up I run through without the disk plugged in and then add the drive.

Looking at the data of the split artists:

  • Another re-index has now sorted that but the only thing I can see that could possibly give an issue is the use of a single quote in their name (they are Irish). Wonder if its a UTF-8 vs Mac vs font issue?
  • I did (earlier today) have a strange iTunes ‘compilation’ flag issue that I’ve corrected on about 30 albums so far. These are flagged as compilations but are not - wonder if I have some the other way causing the spilt? Metadata has been built up over 10-5 years on various boxes and programs so no wonder its a mess (blush).

Just noticed my library has topped 110Gb so the largest SD card in the house will only just hold it and the programs. eBuyer has an 240Gb WD SSD on offer for only £1.50 more than Tescos SD card cost so that may be the way to go if I add much more this year (though my OS drive is 250Gb hmmm…)

When I look at music files in MP3Tag, I sometimes see characters that don’t work in Windows, like you see from a Mac sourced document or similar occassionally. Perhaps those single quotes could be replaced by apostrophes or something to test if that’s the cause of the issue.
The compilation thing might cause a problem, what I had trouble with on compilations was the songs appearing as separate albums. I fixed it by standardising the Album Artist tag as Various Artists, and using the actual artist for each song in the Artist tag. The album title is the name of the album, Hot Hits 1985 for example.
Messy metadata was a big issue for me, I spent a lot of time for days cleaning and standardising it to get consistent display and sorting.
Some people like automated media management, the info is pulled from the internet and applied to the music files. Once I’d got mine all cleaned up (approx 600 GB), it’s easy to check and set the metadata on new albums as they’re added to maintain order.
My music library is on a 1 TB portable USB drive. It’s been working like that for about 18 months now without any issue. I don’t think you need an SSD, mine is the old 2.5" spinning platter type, power is from the R Pi and that seems to have been fine too. Prior to that I had it on a large USB thumb drive.

Thanks for those notes and ideas / hints - I’ll have a look at the Various Artists vs Compilations.

I think I have tracked the quote issue down - on the browse by artist it showed up as:

Screenshot 2021-01-16 at 22.27.18

but when you zoom a long way in I saw the difference:

Screenshot 2021-01-16 at 22.29.29

No idea if that came from my typing or the Internet but as I can only see one of the characters on my keyboard I guess this was downloaded metadata.

Agree over the SSD - I was surprised by the lack of cost difference TBH and have a few 1Tb drives from a NAS I stripped down when the board failed - I’m in the middle of changing a few boxes around the house so I’m sure I’ll end up with a disk or two (to say nothing of a pile of screws / the odd cable etc) :slight_smile: slight_smile:

Read / Write issue partially fixed but at the Linux level…

The Mac share (despite saying it has all rights) does not and is using the ‘other’ security group in Linux to access files and folders.

To fix this I added the write permission to both the track AND directory (album number in my case) with the command:

chmod o+w {track name}  or  chmod o+w {album name}

Now I just need to ‘tweak’ the setting to allow me to add albums but not accidentally delete / rename existing ones :thinking: