Issues with NAS shares Synology


I begin to apologise if these issues have been resolved in any other previous thread but Im probably just a bad googler.

I have bad time trying access my shared folders on my Synology DS718 from Volumio, It works just fine in Win 10.

My setup is;
A first generation raspberry pi
16gig flash mem

Volumio is starting and the sound via HDMI works fine with internet radio

However, when trying to add a NAS share, target folder is a folder containing music files, via CIFS I receive a mount error 95 but it was resolved by adding to “Options” “vers=1.0” or change Synology SMB option to SMB3.0.

A verification for my credentials is requested and then nothing. I try to update/re-scan the library but nothing happens and when trying to browse the folder in Library it shows the /mnt/“FOLDER NAME” but its empty.

I experience the same issue with NFS shares, but at least I receive a message the database shall be updated and the size of the folder is shown but nothing in the “My music” section. It’s empty. And the Library section doesn’t show any folders.

When reviewing the log file I find the access have been denied for CIFS and “username=” and “password=” is empty.
I try to “sudo mount” the shares but fail, my linux skills are just breath from the past.

Hope there is something apparent I have overlooked!


I also had my troubles mounting a folder from my synology NAS.
I don’t know what Error #93 means but I got it going this way (NFS)

  1. Delete all mounts from your Volumio and restart yor Pi

Synology settings (via DSM):

  1. Enable NFS:
    ControlPanel -> FileServices
    Check: Enable NFS Services

3.Create a User
ControlPanel -> User

  1. Create a new user, lets call him ‘Audio’
  2. File Permission: user ‘Audio’ needs to have read/write permissions of the folder that contains your music

4.Create NFS Permissions
ControlPanel -> User

  1. Select the folder which contains your music and choose ‘edit’

  2. Go to NFS-Permissions Tab and and hit ‘edit’ to create an new NFS-Rule

  3. Type in your Volumios IP (You need to give your Volumio a static IP)

  4. Privilege : read/write

  5. Squash: Map all users to admin

  6. Mount your folder to Volumio

  7. Alias: Just give it a Name

  8. IP Adress: Enter your NAS IP (needs also to be static)

  9. Path: /volume1/[Yourmusicfolder]

  10. FileShareType: NFS

  11. Userename: Audio

  12. Password [yourpassword]

click on Update your library and wait (depens on how much data needs to be iported to the database)

Maybe this will help you…

Great it worked! ’
It’s possible my NFS share didn’t work with “read only” but now the shares are loaded.
Minor thing is that I cannot remove a share now but I’ll figure it out or just live with it :slight_smile:

Thanks again :smiley:

I’ve done all the settings you suggest, but still, I get the folowing:

Error in adding network drive
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto ‘r2d2:/Volume1/Music’ ‘/mnt/NAS/R2D2’ mount.nfs: access denied by server while mounting r2d2:/Volume1/Music

Thanks … It worked appropriately ! :love_letter:

Hi mate,

u just need to follow the steps carefully again .

in the **

  1. Path: /volume1/[Yourmusicfolder]


point u just need to paste the path shown in the NAS settings ; shown as "Mount Path "