iptables

I wanted to lock my system down to just ports 80 and 3000 and close the 111, 139, 445, 3001, 3005, 3006, 3007 and 5000 that are open by default.

I use fing to see what ports are open and after applying iptables rules the ports close, so I know my iptables commands are correct.

However, when I try to save the iptables rules (as root) nothing seems to stick after a reboot.

I’ve tried putting /sbin/iptables redirects to a config file with my iptables.rules in it upon start using the /etc/network/if-up.d run

iptables-persistent is not available Volumio says (even logged in as root) and apt-get install iptables-persistent does not work.

I’ve tried iptables-save and iptables-restore, etc, but after a reboot, all ports are back open again.

Is there something else that is preventing the loading of specific iptables rules I am setting that I am missing?

Thanks

Don’t know for sure, but maybe check the security thread and (re)post it there. Seems a good idea anyway to secure Volumio by starting with a deny policy and open up port when needed.

Verzonden vanaf mijn iPhone met Tapatalk