Install Volumio to Internal Hard Drive

Hi guys,
I followed the guide, all steps seem fine but after the reboot I keep geting this

Am I missing something?

The machine is Eee PC 900HA. Thanks!

Hi, it seems you missed something, because this error means the image has not been written to your disk completely or incorrectly.
Please check each step exactly and write down the commands you issued and which disk you wrote the image to.
-Gé-

Hello, I had the same problem as mavsan when I tried to install volumio on my fit-PC2 internal hard drive. Is there any solution ? Or is there any update coming soon to fix the problem ?

I will get a test version ready for you, watch your inbox for a link

Thanks for the img. Sorry for anwsering so late, but i wanted to realy test it before give you a feedback.

Well it doesn’t work and the problem remain the same.

I’m quite surprised to see how hard it is to install it on a simple PC. Especially because you use Debian, everything should be really easy.

First I don’t think it’s a good idea to setup by default a generic user “volumio” and everybody get the same password “volumio” espacialy when my computer is open to the Internet with ipv6 protocol. I don’t to access to my server just on local network. And it’s not easy to change the password.

Secondly, maybe this could interest you it’s an other self-hosted project (but not specialize on audio), also base on Debian and it have on other way to install it :

yunohost.org/#/install_en

particullary one on a already existing Debian install :

yunohost.org/#/install_manually

Maybe you could propose an “howto” to install Volumio the same way ?

Well, that’s because you probably do not see where it goes wrong and what we are actually trying to do there. Let me explain.
The problem is not Debian, that is “only” the distro/ rootfs, the issue you are facing is kernel and our uInitrd related.
We run an init routine to setup a few things, including the volumio filesystems before linux (Debian) gets started and have to support a wide range of PC configurations and chipsets used. Your Asus is one out of only a few we know of so far that don’t work. It is nearly impossible to “guess” what we have missed without having such a configuration here, that is why we need your help. Do you have linux skills and would you be willing to help?

There is a newer x86 image with support for more chipsets, perhaps you should use that one first.

Sorry, the problem has nothing to do with the installation procedure, see above.

It still does not work. With the same uuid confusion problem.

@gkkpch thank you for your explanation. My computer is not an Asus but a FitPC-2. I still don’t really understand the problem since I can install a Debian on it. But it’s because I’m not a dev and my skills are weak.

However I’ve got some little sysadmin skills so maybe I can help a few if you tell me what to do.

@gkkpch

And I don’t understand why there is a built-in user “volumio” whith a weak password “volumio” whitch look as a security breach especially when the network is running with ipv6 and so is wide open to the public Internet.

Can’t you add a procedure to setup a custom password ?

If you’re able to install Debian on it, then I would be really really happy if I could have the “initrd.img-3.xx…x” file from the boot folder.
I can unpack it and compare its kernel modules with the ones we have in our initramfs. This should show us the missing one(s).
Is ipv6 running on your Volumio version?

It shouldn’t, that would be a build error I’m not aware of. Please verify with

lsmod | grep ipv6

and

ifconfig -a

Ok I’ve send it to you by PM.

No you are right ipv6 is not running. I was concentrate on the problem of the installation so I haven’t really look further… And I realize that I really miss-understood the aim of volumio : it’s just aim to play music in the room of the server. I thaught it could be a media server as Libresonic or Ampache enabling listening music out of your own house (in particular on your smartphone with nice offline feature). But it can’t (or not out of the box) and it seems to not be it’s purpose… sadly because the software is great and the web-interface is nice.

Hello,

i have tried to install Volumio to my Hard disk.
That pc is running on an Atom Z510 CPU.

When i boot up form my disk i got that errors seen on the attched picture.

When i boot from USB Device, everthing is ok.

Any ideas?

Thanks

Thomas
IMG_20170208_121742.jpg

Yes, but this is very difficult to solve without having a similar one here.
You are running this with an 8-year processor, what brand of PC is it and which model?
Unless I can lay hands on one I’m afraid I must disappoint you.
Edit: What Volumio version did you download? I might have a later version for you to try.

– Gé –

Thats a small industrial panel pc, no know brand. But i would be thankfull if i can test your newer version.
I have downloaded the latest version from your webpage.

I had Ubuntu running on that pc, there everything works fine, also the touch controller.

By the way, congratulations, a nice pice of software.

Thought so, Axiomtek had things like that.
OK, you will find a “personal” version on http://oph.mdrjr.net/gkkpch/
Look for Volumio-plotv-2017-02-08-x86.zip
Edit The file is only valid for a few days as I’m supposed to use this for Odroid images only.

Cheers - Gé

Thank you, so much, it worked perfectly for me! It’s much faster now.

Another question:

I have internal USB Ports on that Board, the touch controller is connected to it. They are not working. Is this a driver issue or is that also done by the kernel?

And, is it possible to have a normal desktop installed, just to start it from terminal, to calibrate the touch?

Thanks for your help. I think i am gonna change my other music clients too.

Thomas

What type of controller is it, can you do an lsusb -t ?
The kernel is version 3.19 with the same configuration as for Debian jessie, with the addition of overlayfs.
Perhaps the touch controller can be added, but again, I need to know which one it is.

Hi, it is a Penmount 6000 USB. I did install the Driver debian 8. But i got error messages. And i can not find any device.
With me ubuntu 14.04 installation, it is wotking fine.

Lsusb -t is atteched.

Thanks
IMG-20170209-WA0003.jpg

Penmount is supported in our kernel, I will add it this weekend.

Edit: You won’t believe it, from all supported usb touch screens, the penmount was the only one not selected!
And I also know why: support for those only came in 3.18 and when moved from 3.16 to 3.18, I used the config from 3.16 as a template.
Hopefully another issue ticked off, the kernel is being compiled just now.
Check the place where the dev version of the image was stored, that image should be removed and replaced by a new one in an hour or so.
If you would be so kind to test it and give feedback, then I can update our repo later so build a new x86 version can be built.

– Gé –

You are awesome! it’s working.

Do you know a simple way for calibration?

I have an other PC with Elo Serial Touch. Should that image work there also?

Many thanks, i invite you to my next garden party, with my new music player for my grill station!

You’re safe as I fear your garden party is not going to be in my neck of the woods :mrgreen:

Well, sometimes things are easier than they seem.
Penmount appears to be fairly popular, so chances are, someone else will profit from it too.
In case that PC has an ELO USB 4000/5000 touchscreen, then yes.
ELO Serial is also supported, both drivers are in the kernel already .

– Gé –