I get errors that say "failed to decode" and that "CURL failed: Resolving timed out after 10000 millieseconds"

Hi there,

I just setup everything on my Rasberry Pi4. iOS app working, local controls working etc. but I am unable to play anything. I get errors that say “failed to decode” and that “CURL failed: Resolving timed out after 10000 millieseconds”

Attached is my logs


Looks like your DNS settings are not working.

Did you set up Static IP address? If yes, disable it, you might have misconfigured it

Hi @volumio - I am not sure why that might be, I did a clean flash using balena and did not touch anything to do with IP address.

Is there an area in the settings I should be looking into?


Balena is known to cause problems with Volumio. Maybe try Raspberry Pi Imager.

Hi @SimonE - thanks for the suggestion. I just reflashed it with Raspberry Pi Imager, re-authenticated tidal and tried to play and it did not work either. Same error

@volumio - confirming in my wireless network settings I have “automatic IP” set to On and have not setup a customer DNS server, that setting is set to Off

@volumio - setting up a custom dns server fixed it!

Good to know. To which dns did you set? And where are you from and which ISP do you have?

I am in Melbourne, Australia. My ISP is Aussie Broadband.