I can't get an IP address

Hi, I’ve tried Volumio 1.2beta on several different SD cards, but no IP address is assigned to the Pi. The internet connections have been thoroughly checked. Occasionally it does get an IP address, but it cannot be accessed. I have tried one of the cards with Noobs instead of Volumio and it works fine.

My conclusion is that there is a problem with Volumio. Please advise.


Hi, Ifor

I’m running 1.2beta on 2 CuBox devices and have not had a problem. I can’t explain why you should be experiencing a lack of IP address. Are you booting up with the device connected to a display HDMI? Normally, that would enable you to see the IP address during boot…

Just speculating here, but believe I’ve seen Michelangelo responding to queries like this by asking if you have Bonjour installed, which discovers devices and assigns IP addresses (I think).

Alternatively, why not try setting a static IP address?


It’s fine with both Rasbian and Squeezeplug, but not with Volumio 1.2beta. Yes, it’s connected to the TV as a monitor.


The Bonjour install is for Windows. It’s built in to the Mac OS X.

I’m going to try Volumio 1.1beta.

I can see 1.1beta. No problem with IP address, but I’ve not yet worked out how to connect to the music which is stored on an external HD attached to my iMac.

Volumio 1.3beta as well as 1.1beta seem OK, but 1.2beta just will acquire and hold an IP address.