Hotspot says it's online (but it isn't)


edit: I didn’t word this very well, so I’ve added a picture and hopefully been a bit clearer…

I use Volumio2 on RPi3 in my car to create a hotspot wi-fi network so that my devices can connect and send music to the car via the RPi3’s 3.5mm audio jack. Unfortunately, the hotspot network seems to think it is online (i.e. has internet access, see image below). Therefore, my ios phone stops using its own mobile data connection and tries fruitlessly to access the internet via the hotspot (which obviously fails). As a result, my phone is unable to send and receive data via the mobile connection, which is no good on a long journey (traffic updates etc.).

Any ideas how to configure the volumio wifi hotspot to ensure it doesn’t declare that it’s online?!

Many thanks,

I don’t think it is possible to configure volumio hotspot in a way that it does not connect to your phone. However, on the iphone, you can do Settings > General > Reset > Reset Network Settings, which will remove all known wifi networks stored in the phone including volumio. So, the phone will not automatically join the volumio hotspot. However, when you do that, you have to enter the passkey next time, when you join say your home wifi.

It’s not possible (as far as I am aware) to simultaneously connect to a hotspot & use your phone’s normal data connection.

Hi chsims1 and sup27606,

Many thanks for your replies. I didn’t word my problem particularly well so I’ve edited the original post. I’m hoping someone’s aware of how to change the hotspot configuration to change the ‘online’ flag. I’ll look in to whether ios phones can use their own 3G/4G connection whilst connected to a wi-fi network. I would hope that if the wi-fi network indicates it is not online, the phone will default to its own connection.

Many thanks,

It’s not declaring that it’s ‘online’ as in ‘connected to the internet’, it’s simply saying that the hotspot is available. If your phone connects to this hotspot (for Volumio control) then it will not be able to access the internet (traffic reports etc.).

Try it the other way around! Have your RPi connect to your phones hotspot that should have both your phone and your RPi in the same local network and allow for internet connection. Unless you do any kind of streaming you shouldn’t see any spike in internet usage of your phone.

Sent from my iPad using Tapatalk Pro