HifiBerry MiniAmp

Hello.

I am having trouble getting the volume control to work with Hifberry miniamp and a Raspberry Zero. I contacted HiFiBerry. They were extremely helpful and this is what they came back with.

Thanks,

HiFiBerry
HiFiBerry team (HiFiBerry)
Dec 6, 13:26 CET

Yes. It seems, that the onboard sound card is still configured. It is possible that this is used instead of the MiniAmp. I recommend contacting the Volumio developers. They might be able to tell what to do to disable this.


What is the output of “aplay -l”?

My Response:

volumio@volumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0


It’s working with volumio2 on my pi Zero W with Hifiberry Miniamp.
My settings are:
Soundcard: Hifiberry Dac
Mixer Type: Software

I am running the same configuration (hifiberry miniamp on a raspi zero W) and I am having problems. I am running the latest release of volumio (as of today, Release 2.129). I am getting 100% volume occasionally - too much for this amp :slight_smile: and the rest of the time no sound at all. Sometimes, between reboots, “hardware” shows up as an option in the mixer - most of the time it is only “Software”.
The fact that things are so irreproducible is quite frustrating.

So: you say that your exact same setup works. did you do anything else than downloading and flashing the OS?

Cheers,

Chris

I experience the samwe problem of the amplifier on a raspberry pi 2B