Hifiberry Digi2 Pro

Hi all, new to the forum.
I have a Pi 3b+ with Hifiberry Digi2 Pro. I did have it working before briefly with an older version of Volumio, but settled on using HifiberryOS as Volumio didn’t have a digital volume control. I think I had the I2S dac switched to “Hifiberry Digi” as there was no specific setting for the Digi2 Pro.

Decided to check out the latest release as I assumed it would have been updated for the more recent hardware… apparently not yet!

Unfortunately I now can’t make it work at all, not getting anything from the HAT. USB works, but the DAC I want to use is much better via S/PDIF.

Any help on which setting to use? Be gentle, if I have to do anything other than click a setting in the UI I’m out of my depth!

Edit… let me add, I did search, seems others have had same issues, but with earlier versions. I’ve tried using “digi”, digi+ Pro, and even DAC2, none of which are giving me any output. Interestingly the optical output is showing a red light, but the DAC is not locking onto whatever is coming out.

And, no, swapping the DAC doesn’t help!

"Unfortunately I now can’t make it work at all, not getting anything from the HAT. USB works, but the DAC I want to use is much better via S/PDIF."

I’m curious, what DAC are you using? Is it an old model?

Yes… Musical Fidelity V-DAC. The original before asynchronous USB.

The Pi3 USB isn’t brilliant either. Together?.. really not great!

The V-DAC sounds great via optical, so I was going to build it into a box with the Pi and HAT, add a volume control pot, and feed it straight into my power amp.

I can just go back to a different OS, but I’d love to try Volumio 3.

Yes, problem. I’m surprised Volumio does not recognize the HAT. So when you select I2S DAC are any Hifiberry devices listed?

Yes, everything but! Annoying that DAC2 pro is there, but not Digi2 pro.

As I said above, I’ve tried a few of them, but none work.

Just bought myself another memory card… trying Moode!

Hi,

For Digi2 Pro I found the following instructions to get sound out:

Settings/General Playback Options/Audio Output → Enable “I2S DAC” and select DAC Model “HifiBerry Digi+ Pro”. → reboot Volumio

I suspect that the problem is in file “…/app/plugins/system_controller/i2s_dacs/dacs.json” where needsreboot attribute is to false for hifiberry-digi-pro card. @volumio Volumio team, can you check this.

HifiBerry Digi+ Pro 2017 running fine on RasPi 3 Model B Rev 1.2 with Volumio 3.179. Setting “I2S DAC=on” and DAC model HiFiBerry Digi+ Pro.

Has anyone found the answer to the question…?

I just bought the Digi2 pro and it does not put out any audio…!

Is there a text-string that need to be added, or…

The solution for me was change to RopieeeXL which works perfectly with Digi2 pro.

Would prefer to use Volumio but for me, it’s broken.

Ok.

I’ve researched the matter, and found that the Pi4 Revision 1,5 does not support HiFiBerry Digi2 Pro, due to an hardware upgrade that interferes with the startup of the HiFiBerry Digi2 hat.

It’s not something that will be corrected, and not solvable by any update.

Read it on HIFIBERRY’s homepage.

Mines a Pi3B+, so that’s not the issue here.

1 Like

The settings described above are working. Volumio v3.233, RPi2B v1.1 on TOSLINK. I will try the COAX later.

ETA1: COAX works fine.
ETA2: I tried to update to the latest beta v3.239, and it doesn’t work. I had to revert back to v3.233, but it’s working again.
ETA: I couldn’t stand it so I tried the beta again and all is well! v3.241 seems to be fine this time.

From the HiFiberry website:

Digi2 Pro / Raspberry Pi 4 1.5 incompatibilities

We have become aware that there is a new hardware version of the Raspberry Pi that began rolling out in the November timeframe which is not compatible with our Digi2 boards due to a hardware change on the new Pi revision 1.5 board.
Unfortunately this change was not announced in advance by the Pi Foundation, we did not become aware of this problem until February when we began receiving reports of difficulties from multiple customers. For some technical details on this, have a look at this blog post.

Although we have no control over the versioning of boards from Pi Foundation, we recognize the inconvenience this represents to our customers who were likewise not aware of this change. We fully intend to support you in this matter.
We ask as a first step, please see the link below for simple instructions for how to identify the Pi hardware version. Unfortunately neither on the box nor the board you can see the hardware revision. You have to boot Linux on your Pi to run a command: