Hifiberry DAC2 Pro - pi3

Hello guys,

I got myself the Hifiberry DAC2 Pro - as smart as I was; i didn’t check compatibility with volumio before. Or at least I couldn’t make it work with Volumio so far.

Any good hint from experts or information regarding taking this DAC in?
Thanks in advance

Settings >> Playback >>
IS2 DAC ON with your card… and pick your card above :slight_smile:

but there are some problems with that dac…

asla error look here :

Thank you, I had the same error.

I2S: Hifiberry DAC Pro+ (DAC2 Pro doesn’t exsist)
After setup (without restart) it plays
After restart, ALSA “hw:2,0”

Only workaround is; change in playback options to the “DAC Pro +” again; save it; start playback.
But I think this is a very unlucky solution right? So I don’t know if volumio yet fully supports this device?

Sorry for double post, I need to add:

Actually it only looks like it would be playing - but reality is no sound.

i don’t have your dac didn’t find a solution yet … hopefully some one has…

There’s a thread on the hifiberry support page that says to use the DAC Pro + driver as it is the same.


Hello, thank you. Yes - i know this thread.
As above described - I tried that. But it doesn’t solve the restart topic. And it doesn’t solve the topic that no sound is comming out after directly setting the DAC up.
Where I can promise you - with moode the DAC works with these settings - only that i don’t like moode.
So I hope things might continue in this thread - i think this is at least where it kind of belongs to.


I’m having the same issue. Did anyone manage to solve this?

1 Like

Dear All,

I posted what works for me on hifiberry community, maybe can help also someone here.

I think there are 2 different issues that are easy to confuse:

1- the headphones jack cannot work in Volumio, SOLUTION: buy a 4€ RCA to jack adapter on Amazon, end of the story.

2- the DAC2Pro with Volumio after reboot doesn’t work anymore with “Alsa HW 2.0” error, SOLUTION: after the first configuration with everything working fine, switch off the pi, edit config.txt and insert command.

force_eeprom_read=0 restart the pi3.

I have a pi3 with DAC2Pro and in that condition finally everything works fine: jingle at boot, the led on the DCA2Pro turn on when playback, volyme control works, now it’s perfect!


I had the same problem with DAC2 Pro. After I edited the /boot/userconfig.txt with

the line above and the line Hifiberry posted in the Details for DAC2 Pro (dtoverlay=hifiberry-dacplus) anything works. Only the volume control is not working. No Problem because my Amp has a remote. :grinning: :loud_sound:

tomba did you try software volume controle?

i did find this working for the same dac on pi4 …

hi just wanted to say thank you for posting the force_eeprom_read=0 fix that worked!

I have a DAC2 PRO with pi4, 7inch “official” touch in a smartiPI touch pro case

for new people:

-go to volumio.local/dev and enable ssh
-download free tool called putty
-in putty, ssh to volumio.local or IP of your r-pi
-ssh user and password is volumio
-use command cd /boot
-use command sudo nano config.txt
-add the following line anywhere “force_eeprom_read=0” with out quotes
-save, exit
-use command sudo reboot
-in volumio.local > settings> playback options> output device > hifiberry dac plus > CLICK SAVE

  • dont forget to change your volume options on the same page to > mixer type > “software”

Im using rca cable out to my amp > speakers

thanks again!