hifiberry dac+ not working on raspberry pi 3


I have just gotten my pi and hooked a HifiBerry Dac+ to it. I installed Volumio and as a test, first ran audio through the headphones out on the pi. This worked well enough.
Then, I set the i2s audio checkbox to checked and selected the hifiBerry Dac+ as my output, plugged the speakers into the DAC but …no sound.
I checked some knowledgebase articles referring to setting the dtoverlay, but looking at boot/config.txt Volumio already adds that for you when you select what i2s you have. I did check dmesg and found this rather suspicious bit of text:

[ 224.556431] OF: Duplicate name in i2c@7e804000, renamed to “pcm5122@4d#1”
[ 224.563242] i2c i2c-1: Failed to register i2c client pcm5122 at 0x4d (-16)
[ 224.563258] i2c i2c-1: of_i2c: Failure registering /soc/i2c@7e804000/pcm5122@4d
[ 224.563267] i2c i2c-1: failed to create client for ‘/soc/i2c@7e804000/pcm5122@4d’
[ 224.563273] OF: changeset notifier error @/soc/i2c@7e804000/pcm5122@4d

Did I do something wrong while assembling/configuring?

Thanks in advance :slight_smile:

Try to reboot :wink:

That does fix a few things. I now have the 'rpi_snd for the HifiBerry listed in my output devices and it is also listed under aplay -l. However, it still doesn’t actually make noise :slight_smile:
When checking dmesg again, the messages from before are gone and now the only thing I see that might point at a further issue is:
[ 121.227915] pcm512x 1-004d: No SCLK, using BCLK: -2

What else can I do to debug this?

Disable it, save, reboot. Enable it, save it, reboot

let me know

Disabling it also removes it from aplay -l, which seems logical. Dmesg doesn’t really mention it either at that point.
Re-enabling, but not setting it as output, gives it back to aplay -l and also writes to dmesg that at first registration could not be done (will retry later) but then gives ‘ok’ after that. At this point, the device is again listed under aplay -l as well. Running speaker-test -Ddefault:sndrpihifiberry -twav gives an error 16: device or resource busy.
Playing something at this point still gives no sound.
Going in and setting the device from audio jack to snd-rpi-hifiberry-dacplus in the first dropdown in Volumio’s playback settings and saving again gives the message I pasted in my previous post but seems fine for the rest …except the part where it doesn’t actually play anything that is.
In between all these steps I rebooted each time I switched something on or off.