HiFiBerry Dac+ Noise

I installed my HiFiBerry today on my Raspberry Pi B+. I hoped I could cancel all noise.
I’ve already tested with Airplay streaming from my Mac.

The Pi is equipped with a power supply with a ferrite bead, and I’m trying the setup on some refined hifi setup. (I’ve tried both on a Quad and Denon amplifier), but I’m still experiencing a tiny amount of noise. (If I put my ear next to the speakers).

Anything I can in order to try to solve the noise?

Are you sure the noise comes the DAC (not from the amp) ?
Is the PSU a 5V USB ? or other ?
Is Volumio set to hardware or softtware volume control ? (or none)

This is the power suply is 5V (and 2A).
About the first amplifier I wasn’t 100% sure, but on the one I’m testing now I’m very sure. It’s an old-school Denon amplifier (pre and amp separated).

I have “hardware” selected for Volume control, but since Dac+ doesn’t support this I should maybe select “disabled”?

Are you using a switching power supply (small phone-charger-like) ? I 've experienced it quite lots lately using switching power supplies is generating a lot of noise. Also the power that the DAC is outputting is most likely coming from the pi.

Are you using a wired or wireless network on the pi?

I have this power supply: amazon.de/gp/product/B0091CJ … ge_o00_s00
Wired network

Huh?? From the product page on HiFiBerry’s site:

Hardware volume control. You can control the output volume using “alsamixer” or any application that supports ALSA mixer controls (not available on DAC+ Light)


I believe the wired network could be a source of noise. Try WIFI and see if it gets better.

Wifi is not an option here… And I would never want it for my Pi :slight_smile:

I have selected hardware volume control (was the default) but if I turn the sound wheel in the Volumio playback interface, nothing changes. So I thought it was not supported…