Hifiberry Dac+ no hardware volume

I’ve set up my dac with I2S driver and sndrpihifiberry as output.

However hardware volume control does not work even though I have the DAC+. Volume cannot be set any different from 100.

I checked mpd.conf and it has the following settings:

audio_output {

	 type 		"alsa"
	 name 		"Output"
	 device 	"hw:0,0"
	 mixer_control 	"Playback Digital"
	 mixer_device 	"hw:0"
	 mixer_index 	"0"
	 dop 	"no"

Which to my understanding should be OK. I would like the ability to slightly decrease volume to prevent clipping.

Any thoughts?

Tried some stuff myself.

Thought I could try and change volume with MPC commands, but mpc volume [#] does not do anything, it just says problems setting volume.

When I put in the command: aplay -l it says “no soundcards found”. I do not really understand because playback is just fine. EDIT: nevermind, you have to give a sudo command… it shows the dac+ just fine.


I have no problems with this (B+ with DAC+), Volumio 1.55

Menu > System > I2S DAC = Hifiberry +

Menu > Playback > Audio Output = sndrpihifiberry

Menu > Playback > Mixer type = Hardware

Only the first setting is needed, after save & restart the other two should follow automatically.



Thanks for the heads-up.

I did exaclty the same, but on a raspberry pi 2B. No idea if that could be the problem.

I’m not too much bothered about it. I read about clipping on max volume, but I think this is only true for openelec builds and should not happen on Volumio.

I have “hardware control” finally working for my

card 0: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0

I have had the volumio 1.55 distribution updated completely after installation
(apt-get update, …upgrade, rpi-update)
pi@volumio:~$ uname -a
Linux volumio 3.18.11-v7+ #777 SMP PREEMPT Sat Apr 11 17:30:37 BST 2015 armv7l GNU/Linux

amixer yields none of the simple mixer controls mentioned before, but only the following
pi@volumio:~$ amixer

Simple mixer control ‘Digital’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Front Left: Playback 207 [81%] [0.00dB] [on]
Front Right: Playback 207 [81%] [0.00dB] [on]

pi@volumio:~$ amixer set Digital 255
Simple mixer control ‘Digital’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Front Left: Playback 255 [100%] [24.00dB] [on]
Front Right: Playback 255 [100%] [24.00dB] [on]

Intermediate solution: I changed in /etc/mpd.conf the mixer_control
from mixer_control “Digital Playback” to just
mixer_control “Digital”
Remember that 81% already equals 0.00dB!! (100% is +24db - doesn’t sound right?)
Looks like the next Volumio will need some better volume controls.

Hi thanks for your reply!

I followed your steps and it seems there is some difference between you and me, since when I follow your guide, I see with amixer: simple mixer control, analogue. I changed this in the mpd.conf to analogue.

… Oh, I also see digital later on in amixer. Not sure what to change? Isn’t digital the software version and analogue the hardware one?

Hope someone with more knowledge on this can help

Hi Shodan,
Did you search the web (“amixer analogue”), like I did?
Anyway, I suppose you know the answer by now.

I guess your setting to “analogue” did not work.
May be because it’s for the output via the 3,5mm onboard jack?
(by the way - I also see this option, but I presented only the working option …)

regards TaubeNuss

Yes, could not find that much quickly so just tried it. It indeed does not work the way it should, but it still does something. It is however limited to -6dB…?

I think I will disable hardware control completely if I can just manually turn down the volume by command (and at startup) with amixer setting. I do all the volume adjusting by receiver end. I just want to prevent clipping if needed.

EDIT: Changing the ‘Sample rate converter’ in the UI will cause this issue even on a default install of Volumio 1.55 with the DAC+ pro.

I just got this issue after running sudo apt-get update. I was running Volumio 1.55 on a rPi2B with a HifiBerry DAC+ pro. Hardware volume control was working nicely until I decided to update it…

Now running Linux volumio 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l GNU/Linux

I think I’ll just flash the original image again. Any update on what this issue actually is or how to solve it? I don’t want to use software volume control.

I think have the same experience:
No hardware volume control (after updating?).

I was annoyed by clipping on 100% hardware volume, so I first changed it to disabled. When changing it back, it had no effect. 50% = 100%.
(In the process in between I did some updates and rebootes.)

I quess it has something to do with the new version of MPD (Music Player Daemon 0.19.1) ??