Hifiberry DAC+ failing on Volumio 2.502? Alright in 2.029

Hi everyone,
I had a RPI2 with a Hifiberry DAC+ hanging around and I decided to put it to good use.

Long story short, I downloaded Volumio 2.502 (latest) and started up and … no sound. Tried all I could come up with and nothing. I’m pretty sure this combination worked fine in Volumio 1.55 the last I had tested iirc.

I moved to a RPI3, changed the card… no luck. What finally did work was to find an old version (2.029, randomly selected) and it DOES work (pheew the DAC is what matters to me the most).

So, anyone is having this problem in 2.5? Any bug reported? Thanks!

I had similar problem (no sound) with 2.502 and a Hifiberry Amp2 which I believe has the same DAC. Was trying out Volumio for the first time so no idea if I was doing things correctly. Not being patient I gave up quickly and flashed runeaudio 0.5 beta which worked. I have a spare Rpi and a Hifiberry DAC+ so I will give it another try and let you know results.

Thanks a lot Alfred, very interested. :slight_smile:

I have the Hifiberry Amp in another RPI but are not using it now (But now that I think of it… could revive it!)
Also I might try Runeaudio again as they say it now sports SACD/ISO support (I backed up all my SACDs so it would be a real blessing)

I have limited sucess with the hifiberry DAC+ on top of a RPi 3B+. Connected a small speaker with RCA/3.5 cable. I booted the pi with 2.502 on a well used SD card and ethernet connection. Using the android app I checked for updates (none) and ran the setup wizard. Selected hifiberry DAC+.

Attached a HDD with large library and waited a long time for indexing. I could select tracks from library with album artwork displayed but no sound and error message “failed to open alsa device. No such file or directory.”

Then I rebooted with a small thumb drive replacing the HDD drive. No problems selecting and playing tracks from the thumb drive. My earlier failure with hifiberry Amp2 used a different HDD but I didn’t try the thumb drive with the amp. Both HDDs work with both RPis under runeaudio, raspian, openelec etc. so I don’t think it’s a power issue. Dont know if this problem can be fixed with menu settings or code edits or if there is some kind of incompatibility.

I think I will buy another RPi for the DAC and experiment some more with Volumio but meanwhile I have to return this pi to another project.


For the sake of trial and error I swapped the HDD for the thumb drive, rebooted and went to sleep. Overnight the collection had reindexed and was playable! It just took a very long time. First time I waited most of an hour (much longer than runeaudio requires) but apparently it wasn’t long enough. The spinning clock had stopped and the album/song total was correct. As warned I didn’t attempt to play music during the indexing but I did scroll through the screens and study the various menu options and preferences. Maybe I corrupted the indexing process.

Всем день добрый!
Обыскал разные ресурсы,и ничего толкового не встретил

Посоветуйте,где 100% можно посмотретьработу с ежедневной оплатой?
Ставки не интересны.