GUI inaccessible from WAN

Hi there. I have what I think is a very simple requirement, but I am worried that it isn’t supported and/or won’t work.

My Volumio device is on an internal secure LAN that has my media server on it. LAN addresses look like 10.x.x.x

I want to be able to control the Volumio device from the WAN. (The WAN in this case is the semi secure network in my house which includes internal wifi.) Those addresses look like 192.168.x.x

An example of this would be controlling my Volumio device from my Android phone.

Here’s what I tried, and what happened.

The gateway from the WAN to the LAN was set up with port forwarding as follows: port 17999 forwards to port 3000 (also tried 80)

Now, logically, I should be able on my phone to access the gateway on port 17999 within Chrome (or another browser) and be able to load the Volumio GUI and control it from within the browser.

It sort of works. The page comes up, takes a little while, and then I get a spinning wheel of dots forever.

My best guess is that there is some other port that needs to be forwarded or possibly the Volumio GUI code is borked somehow and can’t handle this sort of thing because of out of bound communications.

I found this post

which is incredibly troubling and makes it sound like my desired configuration is impossible and not supported.


I am completely agnostic as to how to accomplish this but conversely every other time I’ve done anything like this, it’s always worked i.e. if I want wifi devices on my WAN to get access to specific services on my locked down internal LAN, I have always been able to simply do a mapping via NAT and it’s worked perfectly.