GPIO Plugin & Volumio 2.344

I cannot get the GPIO plugin to work using the following scenario with Volumio 2.344:

Clean Install
Raspberry Pi B+ v1.2
Monitor plugged into HDMI
No DAC, using Audio Jack output device
USB Microsoft Keyboard/mouse
Touchscreen plugin (I have tried with plugin and without)

Utilizing the web GUI everything seems to work correctly except I have not been able to find a way to make the GPIO buttons work. It’s almost like the I2S bus does not exist.

This same configuration with Volumio 2.296 works great, buttons and all.

Any suggestions?

Further on this issue.

I installed my DAC (Hifiberry DAC+) and was able to get the GPIO plugin working. I then powered down, removed the DAC, powered back up, changed to Audio Jack. Now the plugin works with no DAC and connected to the Pi audio jack output.

Hopefully this will help provide you with enough information to address the issue in my original scenario. It appears that when installing the DAC something is configured that passes on and allows the GPIO plugin to work without the DAC.

Did you somehow change the config.txt file manually?

Hi Michelangelo,
No I didn’t change anything manually. I did exactly as outlined in my second post. I may be wrong but this problem seems to have started after you upgraded the kernel after 2.296. Another interesting thing is that I couldn’t get the touchscreen plugin to load until I unplugged my USB keyboard/mouse, then I could load the plugin, power down, reconnect the USB keyboard/mouse and everything worked OK. Once this was done I then had the GUI on my HDMI display. I don’t have a touchscreen per se - I just use the HDMI display with the USB mouse and keyboard. I’ve noticed that once I have the plugin installed, I can de-activate the plugin and the HDMI display with the GUI still works.