Getting really tired with volumio what works is incredibly slow

Volumio Information

This is really starting to make me think about erasing all volumio installs and buy a cd player.
for the past few months it has become almost impossible to use.
No mater how many times it is rebooted it takes up to 5 minutes to load any instructions and the windows progress line across the top gets to the 99% mark and sits there having a cup of tea. so nothing loads, I am trying to listen to music on my Synology NAS and that doesnt work anymore , I have a CIFS share and use the advanced option of adding vers1.0 to share and that makes no difference. I use windows 10 and the latest browsers to connect but it doesnt want to. I want to roll back firmware to one that was more stable but no one responds on how or where to find them and how to do it. Volumio constantly reboots randomly as well. It is connected to network via wifi with a 5 ghz connection at 425mbps so that is fine with a static IP address. Not sure how to test if it is being blocked by firewall or NAs or something else.
I use pydpiper for lcd information, but that has become a bit erratic lately too with weird crap on the screen. If someone can suggest something logical that doesnt involve coding as I know nothing but can follow instructions I will have a go otherwise it is reformat sd card or go over to Roon.

Volumio Version:2.861
Hardware: RPI3
DAC: IQAudio Pgi amp

Have you tried to flash a new SD card?

This makes me think on a issue with plugins.
Besides pydiper what other plugins do you have installed?

Can you connect via ssh and paste the output of


Hi folks as for the plugins installed I have Tunein radio, Radio Paradise, rotary encoder, and Pydpiper. I havent done a new fresh install yet but it will be a step I will consider yet. I havent tried to SSH in yet as I havent for a while and will have to look up how to do it. It isnt a natural thing for me.
Is there a way to roll back the firmware to an earlier version?
Another thing that is annoying is it may have ben started for say 2 minutes , usually i can play music straight away, but if I click on the setting wheel I get the drop down but if I then click on say “sources” it does not react, the screen changes to screensaver but no information, the progress shoots along to 90% and sits there and about 5 minutes later the page will come up.
The music on my NAS was not available as well, The source was blank, I pressed to rescan and nothing happened, except the slow progress line, then hey presto the music was all there.

I have the wfi and ethernet active though only use wifi and put vers=1.0 now trying vers=2.0 to see if it is any better, into the advance option.
Is CIFS the way to go or should I try NFS shares, which is more stable and easier to use. thanks currently CIFS.
I have tried ethernet cable connection and that was better and more satisfying to use, but not available to use so back to wifi. My wifi modem is less than 5 mtrs in line of sight of volumio.
Rebooted again.
Well you know how it is today 11hrs after posting the first complaint , it started as it was supposed to as usual and works fine so far.
Ah of course I spoke too soon, letting it sit without use for an hour and it is back to playing up, it is almost like it is sleep mode and wont wake up.
It took up almost 2 hrs of my time to swear and curse at it last night so wasnt happy.
I wont be going through that again.
So if there are any tips or hints, firewall suggestions etc happy to try.
And to those who responded so fast thank you I have gotten used to no responses for months but people are busy in life so thank you for taking the time.

From what you describe, this looks to me as possibly one of

  1. Wi-Fi issue
  2. Plugins related issues

Don’t think that 5m is an assurance of working well. The antenna on the PI is very “basic” and it operates on 2.4G, which is easily susceptible of interferences (if you live in a crowded area).
So I definetely suggest to try use ethernet. If you don’t have ethernet near the PI, get yourself a Powerline adapter

This is the solution I use at home (where my 2.4G wireless is super slow due to the fact I live in a crowded area).

The plugins you have installed try to communicate directly with MPD, which in some cases can make it crash. I suggest to either disable them or start from scratch with a new volumio install.

Let me know

Hi volumio
My RPI3 sees my 5ghz network as well and currently is connected at 325mbps so I am loathe to think that is the cause.
In fact using a 1ghz ethernet connection has the same lag issues and it just sits at 99% and then reboots. the radio side of it works a lot better just not the NAS

I will try disabling pydpiper if it happens again. and then one by one if it continues.
Ultimately a new install may be on the books, is it possible to install earlier firmware rather than the latest?
Thanks again

I have started again and installed version 277 and all good so far with the same plugins. on is a RPI3b+ so has 5ghz

PI3 does not have 5G

The Raspberry Pi model 3 B+ Specs. SOC: Broadcom BCM2837B0, Cortex-A53 (ARMv8) 64-bit SoC. CPU: 1.4GHz 64-bit quad-core ARM Cortex-A53 CPU. RAM: 1GB LPDDR2 SDRAM . WIFI: Dual-band 802.11ac wireless LAN (2.4GHz and 5GHz ) and Bluetooth 4.2.

You re right. Forgot that pi3 had 5g.
Anyway 32mb means very poor connection. Trust me, try with LAN.

hi I am getting 325 mbps and by reinstalling a previous version my problems so far have gone away. thanks for replying

It also seems my NAS may have been blocking some access to volumio