Genres / whole Genre added instead of artist/album [SOLVED]

I think this is a bug, but maybe I am doing soemthing wrong or is it intentional?
When I am in the “Genre” view and select lets say “Jazz” and open that directory to add a specific album or artist to the Queue the WHOLE genre is added and the first one is played. What I have selected can be found somewhere in the list.
I tried with different Genres and always the same error happens: instead of adding the specific artist/album it adds all tracks of that genre.
This only happens in the Genre view. In “Artists” or “Albums” it works fine meaning it plays the specific artist/album/song (whatever I have chosen)
DOES ANYBODY HAVE THE SAME ISSUE?? Thanks for letting me know! :blush:


Same issue for me.

So it is probably a bug?? Anybody else has observed this issue?
To me its bothering as I very often go by Genre to select music to suit my mood…

It feels like one, but I’m not 100% how this is intended to work.


Same behaviour for me - this makes using the Genre navigation mode useless - it must be a bug. Running version 2.001.

Just upgraded and the bug still there in 2.021. I flagged in the version 2 thread a few weeks ago.

Appears to be fixed in version 2.026 :stuck_out_tongue:

YEP Fixed in 2.03!! THANKS TO THE DEVELOPER TEAM!!! :sunglasses: :sunglasses: