FusionDsp : the complete Dsp center for Volumio3!

please, give the link, it could be your browser blocking

if one of you want to test, unzip the file in the link in


camilladsp.conf.zip (443 Octets)
save something in the plugin then play…
let me know


I have done a search to find if my question has been answere previously and couldn’t find anything, it seems like it might be a common problem so apologies if I have missed it…

I have a x86thin client running Volumio that I want to use to drive some DIY active monitors. The idea was I would connect my 8 channel soundcard and run my bi-amps straight from the soundcards output by implementing the crossover in Fusion/CamillaDSP.

The Problem:
When I go to create a two input, 8 output mixer in camillaDSP gui I get the error - “Pipeline outputs 8 channels, playback device has 2” however when i run aplay -L via SSH i get the below which shows all 8 channels.

volumio@volu-attc:~$ aplay -L
    Discard all samples (playback) or generate zero samples (capture)
    JACK Audio Connection Kit
    PulseAudio Sound Server
    Playback/recording through the PulseAudio sound server
    M-Track Eight, USB Audio
    Default Audio Device
    M-Track Eight, USB Audio
    Front speakers
    M-Track Eight, USB Audio
    2.1 Surround output to Front and Subwoofer speakers
    M-Track Eight, USB Audio
    4.0 Surround output to Front and Rear speakers
    M-Track Eight, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
    M-Track Eight, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
    M-Track Eight, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    M-Track Eight, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    M-Track Eight, USB Audio
    IEC958 (S/PDIF) Digital Audio Output
    M-Track Eight, USB Audio
    Direct sample mixing device
    M-Track Eight, USB Audio
    Direct sample snooping device
    M-Track Eight, USB Audio
    Direct hardware device without any conversions
    M-Track Eight, USB Audio
    Hardware device with all software conversions
    M-Track Eight
    USB Stream Output
volumio@volu-attc:~$ volumio@volu-attc:~$


volumio@volu-attc:~$ alsacap
*** Scanning for playback devices ***
Card 5, ID `Eight', name `M-Track Eight'
  Device 0, ID `USB Audio', name `USB Audio', 1 subdevices (1 available)
    8 channels, sampling rate 44100..96000 Hz
    Sample formats: S32_LE
    Buffer size range from 12 to 32768
    Period size range from 6 to 16384

      Subdevice 0, name `subdevice #0'

Is there a way to get all channels recognised so I can run this config?

Many thanks in advance!


I found why…
Output device is hidden in camilla Gui to make it simple…
But in your case you need it.
Workaround : edit


and set

hide_playback_device: false

save and reload camilla gui
now you can set number of channels, but do not change anything else

of course, change pipeline and mixer setting

let me know :wink:

1 Like


Music library also doesn’t load. PEQ enabled.

Was it working in the past?
Have you changed something in your system?
Does it work with webradio?

First time I have used it
Have not tested internet radio
Very strange Volumio also stops working, can’t browse media library, Volumio becomes unresponsive

FusionDSP 1.0.32
Volumio 3.396

In fact, mpd probably fails to start because something not compatible in the Alsa stack, and then everything stop to work in Volumio.
You are not alone, but still no clue…
Thanks for reporting

What would you suggest me try? Install an earlier version of FusionDSP?

No interest for a previous version because last changes are not related to this part.
You can try to change sample rate, but not sure it helps…
I’m very annoyed with that

FusionDsp v1.0.33 beta.

  • Internal : chunksize size for better hw compatibility

This update may fix some issues, like no library, no sound, volumio freeze…
This is a beta for testing and please feedback!
Remove previous version, reboot, install
It fixed it for (non exhaustive)
Dell wyse 3040
Virtual BOX (no official support)
Enjoy.and let me know :wink:


Hi Balbuze,

Amazing! Thank you… This solved the problem and I am now getting stuck into the implementation. Thank you so much for your solution and also all the hard work you put into this project. Volumio and FusionDSP together is a match made in heaven.

All the best,


1 Like

Great, I will try it, but I can’t find this version on the Volumio plug in search.

As this is a beta, you have to enable "plugin test’ in IP/dev.
But Warning, in this mode you’ll access to all plugin in beta state, meaning potentially unstable.
Don’t forget to reverse it after you installed FusionDsp :wink:

1 Like

Thanks. It’s working now.

I wish I could turn EQ on/off in an instance to listen to differences. The on/off button for DSP in Volumio quick access meny doesn’t seem to work. Lower right corner, a speaker symbol.

You have to click here

It takes 2-3 seconds.
And please, confirm the version you use, if it works, and HW.

FusionDsp v1.0.33 stable

  • Internal : chunksize size for better hw compatibility

This update may fix some issues, like no library, no sound, volumio freeze with some HW…
If you experience such problem, update to this version and let me know

Enjoy :wink:

1 Like

I decided to try 1.0.33 but within minutes the old problem was back :frowning:
log: http://logs.volumio.org/volumio/0s3K2XP.html

So, it plays then stop after a while?
Is it possible for you to share the contents of


when it happens?


So, it plays then stop after a while?


Is it possible for you to share the contents of /tmp/camilladsp.log

There is a tmp directory on my RPi, at the root level, but there is no such log file inside.