Faild to open ALSA ....

Hallo,
I have Raspi3 with HifiBerr Digi+Pro. When starting to play music, error message occurs:
Faild to open ALSA device hw:1,0. No such device or directory.

“aplay -l” indicates: card 0, device 0. It does not fix together.

In alsamixer I can set “Select sound card: bcm 2835” but I can not save it. There is no button for saving.
How can I set the soundcard to 1,0?
Why volumio not calls hw:0,0?

I hope, you understand my problem and can help me.
Many Thanks
Jan

Did you enable i2s dacs?
To do so:
Playback options, enable i2s dacs, select hifiberry digi+ pro, click save, reboot et voila

Hi Michelangelo,
I2S DAC is enabeld,
Hifiberry Digi+Pro is selected.
But it doesn’t work.
Jan

Could you please connect via SSH and paste the output of those 2 commands?

cat /boot/config.txt

aplay -l

thanks

If it was already enabled, please disable it, save reboot. Then enable, save and reboot. Let me know

Volumio1.JPG
Volumio.JPGHi,

Hi,
I istalled Volumio the second time but nothing has changed.
In my opinion, the sound card is set to card 0, device 0 but what is called is card 1, device 0.
But I know very little about Linux.
Thanks
Jan

I apologize, there is a bug (we just discovered it) in the first config wizard in case you already have selected an I2S DAC which messes up the configuration. The solution is very simple:

  • Go to playback settings
  • Disable i2s, click save
  • Restart Volumio
  • Go to playback settings, enable i2s and select your dac
  • Reboot

Let me know

Bad news. I followed your instructions, but it still does not work.
The same error occurs.
I hope, you 'll find the solution.
Jan

RasPi and HifiBerry are new. I use them for the first time.
How can I see, if the OS recognise and use the Hifiberry card?
Jan

I am having the exact same issue, Raspberry Pi 3 with Hifi Berry Digi+ Pro.

I have tried the steps above. I have also tried starting over from scratch.

  1. Flashed the SD card again
  2. At the setup screen did not enable HiFi Berry Digi+ Pro
  3. Continued rest of setup
  4. Set output to Digi+ pro
  5. Rebooted
  6. Loaded a song from library
  7. Error occurred again :frowning:

I am seeing the same output of the commands as janx

Investigating as we speak

I am trying to replicate your issue, but I can’t… It just works…

Do this: disable i2s dac, save and reboot.

Enable I2S DAC, select Hifiberry digi+ pro, click save. Reboot

And it MUST work…

I did:
sudo nano /etc/mpd.conf
and set “audio output” to hw:0,0 … .save … reboot.
The error massage did NOT occur, but there is no sound out of Hifiberry anyway.
The left indicator for the time of the song moves now.
By the way USB output works.
Jan

Could you please just do what I suggest???

I did:

  • Go to playback settings
  • Disable i2s, click save
  • Restart Volumio
  • Go to playback settings, enable i2s and select your dac
  • Reboot

as you suggested.
But no sound.
I think, my sound card is not recognised by the OS??
How can I see it?
Jan

Now working:

Steps to demonstrate working behaviour:

  • download latest build VERSION: 2.296 RELEASE DATE: 18-10-2017
  • put image on sd card
  • follow wizard
  • select digi + pro as dac during setup
  • setup nas during setup
  • skip network setup
  • played music
  • :: No more error! ::

Thank you very much for fixing in this version it seems to have done the trick

Hi,
now it works.
It was an hardwareerror. Digi+Pro did not work properly.
Many thanks.
Jan