External USB HDD not reconized after version update

Volumio Version: 2.909
Hardware: RBPi 4 in an Allo DigiOne Signature Player
DAC: External SMSL SU-9

I have an Allo DigiOne Signature Player which comes fully assembled and ready to use, with the OS already installed in the card. However, the Volumio version was the previous to the current 2.909, so Allo staff indicated I could simple download the latest version and flash the card, which I did.

With the original Volumio version factory installed (by Allo), I connected an external HDD with music in it, this HDD was recognized by Volumio and appeared in the Music Library section. However, after flashing the card, the HDD is not recognized anymore. The green bar that runs left to rigth on the upper section of the Volumio page scans until the end on the right, but the USB device does not show up. I already attempted Rescan/Update, unplug/replug the USB, changed to another USB port, restarted the OS. Nothing works.

Any ideas what could be wrong and how it can be solved? Simple solutions are appreciated as I don’t know how to fiddle with commands or tools in Volumio.


Do you have extra power for the USB-HDD ?
For me , only my SSD works without on the USB 3 connector ,
Normal HDD’s are only working with extra power .
Otherwise did you try the HDD on your PC ?
Maybe it’s gone .

Thanks for your message, but no, this HDD does not require external power, and I did try the HDD in my laptop and works just fine. Like I said in my original message, it worked with the previous version of Volumio installed in my RBpi before the upgrade. Must be something in the way Volumio controls the disk through USB, which is what I hope someone in this community may know how to resolve.

Good day!