External hdd issues

Hello fellow volumios!

I have an problem that I cant solve by my own.

Problem:
External 1tb usb disk with own powersource and an Rpi3b+with iqaudio dac plus, volumio version 2.368

The disk Does not show up in volumio but after some restarts of volumio and pi an unplug usb disk it shows up, but i can only se a couple o folders not in close all music.

I have tried to run both update library update and search library again but nothing happens and tried diffrent versions of volumio and the problems is The same, sometimes volumio finds The disk and I can play music from it for a day, but then next day I’m back were I started

I have run a couple of commands that finds my disk and shows the whole thing.

I just want to fix this problem so I just can plug in my usb disc volumio finds my music
So I can use my whole music library.

I attach some pics.

Screenshot_20200322-083934.png

Screenshot_20200321-160441.png

Screenshot_20200322-083934.png
Screenshot_20200322-085059.png

Update:

I have now made an clean install at sd card with volumio latest version 2.729.

Plugged my usb-disc into rpi3 and in volumio tells me that it only find 1 album and 15 song. nothings happen when I press update or search again in sources->my music

When I got into rpi via ftp I find external hdd in mnt/usb (a shortcutsign at usb folder) that takes me up to /media/wd1001/Music there i can find all my album folders and music.

Feels something fishy, do I have to manual mount my disc ? if yes how?

Anybody help ??

I am no expert but I had issues with the recent builds (2.713 mostly) and my external 1TB SSD. Try sharing your Volumio logs (volumio.github.io/docs/User_Man … oting.html) and we will be able to check what’s going on.

Have you tried saving your playback settings? Sometimes this works. Once done, go to Settings / Sources and hit Rescan, see if it starts updating.

Sometimes it takes a few restarts as well…

Ps. I had to flash 2.699 and since then everything works just fine. Not upgrading for the time being…

Thanks for some answers after you mentioned it I tried save playbacks settings restart and scan, and some couple more tracks appeard.

I found the log , could it be that wav-file that compromise the whole system ?

http://logs.volumio.org/volumio/bsOsPma.html logfile

It certainly look like it, however it’s weird that it’s repeated so many times. I would try 2 things:
1- try removing that file from the HDD to somewhere else and see if it can continue scanning the rest of the HDD.
2- it could also be that the HDD or the USB cable are not in good shape. Test both in a computer…

Thanks!
Update, I plugged my hdd into another rpi with raspbian os, hdd shows at desktop then suddenly hdd disapeard and then Come back again, so I changed usbcable and after that It went stable, (couldnt remove files because of some permissions)

Anyway plugged hdd back into volumio rpi again after som restarts volumio find my disc everything seems to work, until this morning I’m back in sqaure one. Maybe I post log file later.

If it’s still acting like that I would flash 2.699, for me it’s working like a charm and all I want to do is play some tunes, not getting crazy looking here and there to fix things. This version just works, give it a try if nothing else works.

Same here too much fiddling around, I do a search for 2.699 version.