Expand file system on volumio 2


I am using volumio-0.979-2016-08-20-pi on raspberry pi 2b
I followed Increase the partition size guides at faq but cant success.
after deleting and rebooting my system cant boot.
is there any differences on volumio2 to expand filesystem to whole sd


It does it automatically during the first boot.

but i got no free space error when installing apps.

df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p2 2.0G 529M 1.4G 28% /imgpart
/dev/loop0 263M 263M 0 100% /static
overlay 5.0G 352M 4.4G 8% /
devtmpfs 479M 0 479M 0% /dev
tmpfs 487M 12K 487M 1% /dev/shm
tmpfs 487M 33M 454M 7% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 487M 0 487M 0% /sys/fs/cgroup
tmpfs 487M 884K 486M 1% /tmp
tmpfs 487M 0 487M 0% /var/spool/cups
tmpfs 487M 13M 474M 3% /var/cache/apt/archives
tmpfs 487M 328K 487M 1% /var/log
tmpfs 487M 0 487M 0% /var/spool/cups/tmp
/dev/mmcblk0p1 61M 29M 33M 47% /boot
tmpfs 98M 0 98M 0% /run/user/1000

Is this normal?

You have 4gb free…

You both are correct, but I experienced the same problem. The partition “overlay” is not used when installing packages, at least not at default. I’ve run into the same problem trying to install all MPD dependencies to cook a new version. Haven’t tried to resize partitions just yet, because I don’t want to brick my installation. :slight_smile:

This happens because we mount the apt cache on RAM, so actually there is no space to dowload package, but there’s plenty for installing…

Try to place a # in front of tmpfs /var/cache/apt/archives on /etc/fstab and reboot…

Let me know if that solves your issue. If that works, it will be default on next volumio versions

Works like a charm! I was able to recompile mpd (had to install 1.5Gb of packages), so the test is successful.
But the main thread was about being able to install packages, this solves it! :slight_smile:

github.com/volumio/Build/commit … 21eecdfc6e

From next version there will be no more apt problems…

Problem solved. :slight_smile: