Easy installation question


So since this is my first question here ill go easy on myself…

Ive installed Volumio on a new sd card just now, using Etcher… no problems there…
Ive connected the Pi 2-B to that official 7" touchscreen…

So booting up, i expect to see Volumio on my touch screen. first problem…
I read somewhere to use “sudo apt-get update” this seems to work

But after updating, rebooting, im still in the command line, when i just want Volumio to start…

I think job wel done (awfully) for my first question, reading this might also indicate my amount of knowledge around Pi, which is sweet f.a. …

Much thanks in advance anyone!!

Also, yes, ive tried looking for a topic which must already be there, but its my first time around here, and couldnt find any, and the topics i did find on the whole sodding internet dont describe my situation with the touchscreen anyway :wink:

In order to use your touch screen you have to install the required plugin. Have a look in the plugin collection on the development talk forum. But to do this, you have to access your device from a computer or smartphone.

Hi and thanks already!

Well, first i went with Runeaudio and that booted into the programme immediatly but … i want volumio :slight_smile:

What i did find out is the ip adress and using Putty i was able to get the command line from my laptop and do… things…
Also, when i first hooked up the screen, i had Kodi installed from a time back, that worked as well…
Ill try again to get acces to the thing, and check out those development forums!

Ok i cant get into my Pi using Putty…

I know the IP adress but i get a timeout …

Im thinking i just pissed away a lot on all this stuff on which whatever i ready and try, nothing works…
I read hostname -I, that doesnt work either

I cant think of what to do next…

Ok i flashed the image again, did a sudo get-apt update, reboot…

when im in my browser and go to volumio.local i can see the screen but it keeps loading and loading and nothing happens.

Also on the touchscreen the same command line, so still nothing works :frowning:

What happens when you type the ip address of the raspberry pi in a browser.
And sometimes the first bootup takes a while of patience.

You do not need a sudo get-apt update to flash the image and let it boot slowly, then type the ip address of the raspberry pi in a browser then go to settings / plugins and download the touch screen (Takes a while)
once downloaded reboot the raspberry pi, once Booted go back to settings / plugins and activate the touch display.
pay attention! It takes a while before the display comes out.

ps, ik woon trouwens ook in nederland :smiley:

Krijg nou de t…
Translation: oh my!

Edited, ive picked up a Pi3 cause the plugin details said a pi2 was not reccomended.
Trying not to flip my shit when i couldnt connect to the pi anymore but its because it got a different ip adress. Now im in again and installing the touchscreen plugin.

It tends to get stuck on 70% though so i refresh page, install again and it finishes succesfully.
Then i Enable touchscreen in the settings and reboot,

AND STILL it only gives me a black screen with the cursor (which does respond) nothing else…

What on earth do i have to do to get this thing working?
ive followed all steps on this one volumio.org/raspberry-pi-displa … ic-player/
But still im nowhere…

After updating the pi according to a tutorial for touchscreen setup, i got this:

I dont know what this is, but i still get no Volumio

I do not know what that is but certainly not volumio
So somewhere you’re doing something wrong.

This what you need to do, download volumio and extract the zip file.
Download win32disklmager and Install it on your windows pc then download SDformatter and install it also on your windows pc.

Put a mirco sd card into your windows computer then open SDformartter and run it as administrator and click on options and choose (format size adjustment) and turn on the value (on) and click format (note that you choose the right drive).
When done, open win32disklmager and choose the volumio image file you just unpacked and choose write.
When the writing is complete, remove the micro sd card from your PC and put it in the raspberry pi and turn it on.

Wait for a while sometimes 5 minutes if volume is fully started log in through your ip address
Or http: //volumio.local/ download than the touch screen plugin sometimes it stays hanging at 70% just let go this is normal and can sometimes take fifteen minutes, once installed reboot volume and activate the touch screen plugin.



Thanks for the help my fellow dutchman, ill certainly give this a go tomorrow!
I did a few update commands i got from the tutorial on how to setup the screen, after i did the setup stuff from volumios site, i did actually do all those steps as you mentioned above but then i get a black screen with just a cursor.
I think doing those update commands got me this new screen, looks like raspbian…

Thing is, when i just flash the image, i can access volumio through the ip adress, and install the touchscreen plugin, then when i reboot i get the command line, but if i switch the screen to Enabled in the browser, theres just that black screen with the cursor, when i Disable, i get the command line again…
My mate told me i just needed to install Volumio and it would work, clearly it hasnt worked for me so far…

Fresh start tomorrow then… and thanks again, ill try windiskimager instead of Etcher

Too bad that you do not get it right.
What you can do is turn on your raspberry pi and go to the volumio download page and then go all the way down the page to (connect to it) and click on (volumio.local /) that way you make direct contact with Your raspberry pi is its IP address.
If you’re not sure which IP address the rapberry pi has, you could also use an android app (fing) to find the ip address, there will also be an iOS app for.

play.google.com/store/apps/deta … droid.fing

good luck!

So ive done all that, still gets stuck on 70%, i reinstall then it finishes, but still a black screen when i enable the plugin.

Im thinking of opening the nearest window and chucking this thing out, at least youre trying your best to help. all other forums so far have been useless

Fuck this thing

From your postings you seem to be confusing Volumio with Raspbian disk images. Have a read through of the link at the base of my post, and start again. You can worry about your screen when you get the base software up and running (accessing it from a mobile or PC etc.). Hope this helps :slight_smile:

I think youve hit it on the head there mate,
ill certainly read into that link, but i did find out through trying to first install the volumio software, then attatch the screen…
Strangely every time i installed it kept freezing on 70% and did the same this time around, but when i now plugged in the screen, it just worked!

So now ive soldered header pins onto the hifiberry and hooked it up again, still works!
(the difference in audio quality from the 3.5 jack to the rca from the hifiberry is enormous)

Now i just need to find a good value potmeter for volume control and figure out how the mausberry works…

We’re getting there!!

Thank you guys for your time