Distorted sound with Audiophonics Sabre DAC, all formats except webradios

Volumio Information

Volumio Version:volumio-2.873-2021-02-19-pi.img.zip
Hardware: Raspberry pi 3b+

I was able to enjoy my setup for one evening, perfect sound. Next day, after reboot, terrible distortion, metallic sound !
(I tested my amp with another source, no problem there.)

During random tests with the DAC I tried a web radio, and it worked without distortion !
All local files (mp3, ogg, flac) have the same problem.
I noticed the initial sound played at startup is also distorted.

Could it be some sample rate issue ? How can I force the use of a specific rate (I know this is
supposed to be automatic)

I tried the generic I2S DAC and the RPi DAC settings. Same problem as with the audiophonics driver.
I have not updated/upgraded anything in the meantime.

So, something has changed in the meantime. Can you generate a system log please Sending logs for troubleshooting - Volumio Documentation ?

Well, thanks for your comment!
Unfortunately I had reinstalled fresh while trying to solve the problem.
Here is a log anyway but it does not cover the period during which the system worked
BTW, I just tried to look into that link and got a 404 error…