Disappointed - I Wanted Volumio To Work

Greetings,

I have decided to cancel my annual account, which I am sad about. I bought a Raspberry Pi 4 and Flirc case, and it has been very buggy and undependable. I have had to reinstall Volumio twice, which isn’t hard, but it shouldn’t be necessary. The first time was after Qobuz got borked. The second time was after I was completely unable to connect the app on my Android phone with the Raspberry Pi.

I have had a number of occasions where an album on Qobuz only plays 30 seconds of each track. Other albums by the same artist, is fine - or on other occasions I was able to listen to the whole thing.

Skipping forward on Radio Paradise, has never worked. And the fact that I cannot sign into my RP account, so I can listen to a stream of my favorites - is a YUGE bummer. On a number of occasions, I can’t see the album that is playing.

The interface is clunky. I don’t want any of the sources that I am not using to show up, and the ones that I do listen to - Qobuz and Radio Paradise - to be at the top.

The last straw has been on several occasions, I am listening - and it just STOPS. And then there is an error, and my phone cannot even connect to the Raspberry Pi. I try reloading the network address (the Volumio.local address has never worked, either), and it is hit or miss. If I can’t get it to connect, I then have to reinstall Volumio.

Before I got the Raspberry Pi, I used a Windows computer, and it worked almost flawlessly, and I didn’t have to pay another fee. The Raspberry Pi is low cost, and the Volumio subscription is reasonable - but it has to work. It is a great concept, but sadly I can’t enjoy music if it keeps breaking.

Sorry to hear about your problems Neil, but they aren’t the typical experience. Reinstallation can sort problems, but it doesn’t tell us what the original problem was … was it something introduced by Volumio for example, or as a result of your use of Volumio, say by installing plugins.

“Qobuz got borked”

In what way, did you try to problem solve, ask for help?

“Skipping forward on Radio Paradise, has never worked”

Same questions as above. Personally, I have never had any problems with this plugin running flawlessly.

“The interface is clunky.”

Obviously subjective, and I agree that there is less control over the user display than would be ideal. You do realise though, I hope, that the sources on display can be turned on/off (but not reordered) from ‘Sources’ under 'Settings.

“The last straw has been on several occasions, I am listening - and it just STOPS.”

Again, help us make this software better by finding out why this is happening in your situation, because it is not a general problem.

“The Raspberry Pi is low cost, and the Volumio subscription is reasonable - but it has to work. It is a great concept, but sadly I can’t enjoy music if it keeps breaking.”

Totally agree, so let’s see if we can sort your problems, and improve the experience for people following in your footsteps. Sending a system log when a problem occurs is pretty straight forward, and can help diagnose what is happening in your setup.

Edit: Btw on afterthought, this reply to your post was not intended to persuade you to keep up your subscription to MyVolumio. I am not affilated with Volumio other than as a moderator on the forums. As a Volumio user, I simply wanted to say that your experience is atypical, and it would be useful to find out why you are experiencing difficulties.

1 Like

Hello,

I did ask about Qobuz here on this forum, when it stopped working, and there were others who had the same problem. It affected Tidal as well, I think. All the suggestions to fix it, didn’t work, except reinstalling Volumio.

And I have posted questions about the RP plugin not being able to skip forward, and the nasty buzzing noise it makes when I try.

Okay, I am sure I missed a lot of capabilities, for customization. I found that many times when I thought it would do something, when I tried to do it, it would back out of the screen, and I would have to dig back down to where I was. I use a lot of software for decades, and I earn a living using CAD, and I had no luck trying to find stuff. The labels in Qobuz are different than they are in the Qobuz computer app.

On it stopping - I start a stream, and listen for a song and a half - and it stops playing mid song. I try pausing and restarting, and I try reloading, and I try typing in the network address (192.168.1.121 - because the [Volumio Name].local thing never worked), and nothing worked. It then had a error message, which was the device can’t be reached. The last time that came up, was the second time I had to reinstall Volumio.

I came back a few hours later - and it worked. But only for another several minutes - and the same error message came up.

I have been trying to get it worked out for months. It worked some of the time, and then another problem crops up. The 30 second segment on Qobuz would happen for an album that I had listened to, and made a favorite - and then I would try to listen again, and only got the first 30 seconds of each track. I asked on this forum about it about 4 times.

I could choose a different album by the same artist, and be able to listen to the whole thing. No rhyme or reason - and this only happens with the Volumio Raspberry Pi. I have used a Windows computer for both Qobuz and RP, and RP on my phone, and never have these issues.

I have repurposed the Raspberry Pi already (actually my son has) to be used as an ad blocker on a network. And I have canceled my Volumio subscription. I am getting a streamer that will let me sign into RP so I can listen to my favorites - which is a large part of what I do, when I can. I will use my Schiit Audio Bifrost 2 DAC, rather than the DAC in the streamer - I am getting it for it’s solid software interface.

Hello Neil,
the series of problems you described sounds to me like there might be a network problem that could be the cause of all these issues. Did you try to connect your Pi via LAN or WLAN (or both)?
My RPi3B here did never show up with problems like these. I already used it with several releases and beta versions of Volumio - via LAN and WLAN.

The Flirc case is made of aluminum - that might have a bad influence on the wifi performance - especially in the 2.4GHz band…

Best regards,
Robert

1 Like

Hi Robert,

It maybe a network issue, but I doubt it. We have a Mesh wireless system, and the one unit is about 14 feet away. It went for weeks or days without problems. So, if it is a wireless network problem, it is pretty random.

The Qobuz issue with playing only exactly 30 second clips of each track of some albums, on some occasions, would not seem to be a network issue. The skip forward issue seems unlikely to be a network issue.

The Qobuz plugin getting corrupted doesn’t seem to be a network issue, either. Even the error connecting the Android phone app to the Raspberry Pi doesn’t seem to be a network issue - it took reinstalling Volumio to work.

It worked fine, and then I switched to using the Windows computer for a while - so I can listen to my Favorites on RP - and when I plugged my DAC into the Raspberry Pi a few weeks later, it failed to work.

Hi, this has nothing to do with Volumio or Qobuz. I’ve dropped this question to Qobuz, as some albums have 90% of 30 second tracks. I think this is a winner. Al light grey tracks are 30 seconds long:

this is their answer:

Hello,

Some albums are only fully available through the purchase in our download store due to a decision from the label and / or the distributor. We are sorry.

Best,
Qobuz Customer Service

1 Like

Hi Neil,
just to be sure - do you have the oportunity to connect the Pi via a LAN cable to your network? It would be very interesting if it helps (except of the QUBUZ issue for which Wheaten seems to have discovered the reason…)
Cheers, Robert

1 Like

Hi Robert,

I did not try a network cable. The corruption of the Qobuz/Tidal plugin that was my first major issue was experience by a lot of people. The skip forward function is not a bandwidth issue. And the inability to reconnect to the Pi, that required a reinstallation of Volumio was not a bandwidth issue; because it worked after that.

I did wonder if this was the case. But this should be made clear in the display of the album; like saying download only.

In one case, I was able to listen to an album in its entirety, and then later, it only played 30 seconds - and there was no change in how the album was displayed.

I haven’t seen any notice in Qobuz, when an album has truncated tracks. Only thing that I see in Qobuz are black or grey tracks.

Thanks for sharing your experience. This is useful for us to improve.
I 100% agree with the previous suggestion: first I will diagnose Wi-Fi as it looks to me that this might be your N1 problem.
PI in itself has really poor wifi range, and enclosed in an aluminium case it will get worse for sure.

The fact that it used to work can and now it does not can be due to 3 factors:

  1. PI Antenna degraded or Wi-Fi chip degraded. Over the years I have multiple PIs which Wi-Fi simply stopped working… That’s just my experience and I don’t want to assume all PIs have this issue.
  2. One neighbour started another wifi network, which overlap frequencies with yours. Usually Wi-Fi (especially 2.4G) work really poor in crowded areas due to frequency overlapping.
  3. Check your Power Suppy: a good, steady 5V,3A PSU is vital to the proper working of Raspberry PI

At home, when I can’t use wired connection, I personally use a powerline: I get very fast response from Volumio and I can play even Hi-Res files, without having to run a LAN cable.
I would suggest you to try this route:

Let us know

1 Like

Just a cautionary note about powerline adapters before you rush out and buy one. The throughput you achieve in real life is very much dependent on the existing wiring in your home. I know lots of people who use them successfully, but in my (old) house they are an absolute nightmare. If possible, try before you buy. :wink:

1 Like

+1.

They will run pretty stable when connected on the same powerline (group).
If it needs to go through a fuse box, it’s terrible. Connection loss, data loss and interrupted services.
Don’t use any extension cable.

you can also use WiFi extenders, but keep in mind that every additional extender will lower the throughput speed.

I appreciate the suggestions, and concern. A few months ago, we upgraded to a Netgear Nighthawk MK62 Dual-Band Mesh AX1800 WiFi 6 System 2 Pack, and the signal strength was improved. The Raspberry Pi 4 was brand new, and it was located about 20’ from one Nighthawk unit and about 14’ from the other. The Raspberry Pi was working fine on our old wireless system, which was a Verizon wireless router, and a separate wireless router with another network name - two separate parallel systems.

If my ~$100 Pi 4 only lasted about 4 months, then what does that say about anybody using this for their main source of music? By the way, the reason I got the Pi 4 is because it has much better USB, and I have the Schiit Audio Bifrost 2 DAC which has an excellent USB input. This way I didn’t need a HAT to get a coax connection.

The very first problem I had was the corruption of the Qobuz/Tidal plugin. This was a confirmed bug, that many people had occur. And the Volumio.Local connection method never worked for Android. We had to discover the network address, and type that into the phone browser.

I’ll say again, that for me, this is a moot discussion. The Raspberry Pi 4 unit has been disconnected and has been reformatted, and will be used for another purpose. I have canceled my Volumio subscription. My new streaming unit is arriving today.

Hi Neil,

anyway, it’s a pity you didn’t ask for help or support when the problems occurred. This community here has a good culture of troubleshooting and getting things run.

Regarding the performance of several Raspberry Pi housings I found a imho informative page - may be helpful also for other users:

@volumio: Powerline LAN adapters are applied here as well. I bought some dLAN duo 550+ from Devolo which are quite reliable and performing well. They offer two LAN plugs each which I like. dLAN® 550 duo+ - Mehr Reichweite für Ihr Heimnetz

Take care,
Robert

1 Like

Hi Robert,

I did ask for help on each of these problems, when they occurred. I got a few suggestions, and I tried several of them. I went back and posted to the 30 second problem on Qobuz several times, after I had it happen again.

The reason I chose the Flirc case is because it is passively cooled. Tiny fans make a lot of noise, very often.

To be fair, this is due to Google not adding mDNS support to Android.

You can voice your interest in their issue tracker here (if Google ever listens): https://issuetracker.google.com/issues/140786115

Understood, but I have to work with what I have. This situation is an accumulation of problems - if the unit had kept working after the initial setup, then the Volumio.local issue is not a problem. I had to reinstall Volumio twice, and had numerous times when it just quit working.

The lack of being able to sign into my Radio Paradise account was a compromise already, and then having several other issues added, took away my ability to just listen to music. Which is an important thing, for me.

Yeah, I see what you mean.

Anyway, I hope you enjoy your new streamer (is it a Bluesound?)

Did you tried Sound@home for Volumio App? This app will discover Volumio for you and will add it automatically :wink: