Disable the captive portal but keep the hotspot?


I use Volumio in a particular configuration, I don’t have a box, my home is not connected to the internet and I don’t have a WiFi access point.

Therefore, I can only access Volumio through its hotspot, from my phone, tablet or computer (and it doesn’t matter, I don’t need internet on my Volumio).

My problem is that once connected to the Volumio hotspot, a captive portal opens and I am forced to go through it to access Volumio. If I close the captive portal, the wifi connection also ends and I cannot access the Volumio interface through my browser.

My question is: Is it possible to deactivate the captive portal and still have the hotspot?

  • Volumio 2 or Volumio 3 Beta RC1 (same problem).
  • Raspberry Pi Zero 2 W + Allo MiniBoss Dac
  • Raspberry Pi Zero W + Hifiberry MiniAmp
  • I access it from Apple machines.

I certainly have used the Volumio hotspot in the past in my car (a few years ago, so stuff may well be different). Are you sure that you have the hotspot enabled in the wireless network settings? If so, you should simply be able to connect to the UI through

To clarify, the hotspot is working fine, if I access the Volumio ip address, it works fine.
My problem is with the captive portal, on Mac, I can leave it open and go through the browser, on mobile, the captive portal is a modal window, so I cannot access anything else until I close it. However, if I close the captive portal, it disconnects the wifi connection with the Volumio hotspot.

Sorry, I do not understand what you mean by a “captive portal.” Can you post a screenie? Why can’t you directly access the hotpoint and then ‘’ from your mobile (without involving your mac)?

On Mac, just after connecting to the Volumio wifi hotspot :

If I close the captive portal window on Mac, the wifi connection remains active and I can access the Volumio interface from a browser.

On iPhone, just after connecting to the Volumio wifi hotspot :

If I close the captive portal modal on iPhone / iPad, the wifi connection is interrupted and I cannot access Volumio from a browser.

OK, I found a solution, not very elegant, but it solves the problem.

You just have to connect to Volumio via SSH.
Edit the /etc/hosts file
Add the following two lines: captive.apple.com connectivitycheck.gstatic.com www.google.com play.googleapis.com

Save, reboot and no more captive portal on Apple et Android devices.

I think you are misunderstanding the purpose of the hotpoint, or I am not understanding how Apple products work. ;).

The main use for the hotpoint is to initially access the Volumio UI, and set the required wifi network settings ie. local network ssid, and password. Once this has been done then you no longer need the hotpoint: just logon to local network and go to the appropriate device IP address.

Edit: have you gone through the first startup menu, where lots of settings are made?

I understand very well the interest of the hotspot for preconfiguration, OK, but I don’t see what prevents me from using it as a traditional wifi hotspot to access Volumio.

As mentioned in my first post, the particularity of my installation is that I don’t have a wifi network in my home, so I have to make do with the Volumio hotspot. I’m not going to install a wifi router to control only Volumio, it’s an ecological and economical nonsense.

In this case, the fact that the captive portal opens is not an Apple problem, but a behaviour that can also be found on Android or Windows machines (hence the second line for the hosts file). This is because there is no internet connection behind the hotspot.

I select ‘cancel’ and ‘use without internet’ from the portal.

Curiously, this method doesn’t work anymore, I don’t get the call to action, it just closes the connection with the wifi.

I haven’t tried it lately - but I seem to recall that I needed to give it a few (10?) seconds otherwise it would close the connection.

Sorry, I made my post #7 without going back to re-read your original post about no internet. I still do not see the function of the “captive portal” on your mac.

@Old_Duffer Thanks, I’ll try to be patient next time to see if it works.

@chsims1 Check out my two screenshots on this previous post.
On the first screen (Mac), you can see on the status bar (bottom) the address of the captive portal.
On the second screen (iPhone), it’s at the top, just under the clock.

Yes, I can see this. What I am questioning is why you need to use the “captive portal” or even what it is … you have never explained. Anyhow, this is is obviously my ignorance with the Apple ecosystem. I will bow out and hope that you get it sorted.

@chsims1 I partly explained this in the last paragraph of this post :
Quand un système “moderne” (Apple, Google, etc.) se connecte à un hotspot, que celui-ci n’est pas connecté à internet (pour cela, il ping captive.apple.com, connectivitycheck.gstatic.com, www.google.com or play.googleapis.com selon l’os) et que l’adresse du routeur est équipé d’une page web, le système part du principe que c’est un portail captif et affiche la page en question dans une fenêtre (modale sur smartphone).

The solution is to reroute the traffic from the ping addresses locally.
The OS is no longer able to know whether there is internet on the hotspot, it does not assume that it is a captive portal.