dac issue

Hi there,
I am not able to take sound from Vimio trought a DAC I have used before with Raspyfi. It is connected by HDMI to a TV and I as I see there everything is OK

Do I have to change anything somewhere to be able to?


If you connect HDMI, then Audio is routed through HDMI. But you can easily change the Audio output. Just go to settings -> Playback and select your USB DAC as output. Done.

Let me know!

Hijacking this thread. I only have two choices in settings ->Playback. “L20” and “Alsa”. None of them gave any sound from my DAC. I had to change
device “hw:1,0”
device “hw:0,0”
in /etc/mpd.conf to get the sound through my DAC.

Ok, that is interesting. Just to check. After you selected the output device, did you click on “Save changes” ?

OK right! that´s what I did and worked fine with de ODAC. It didn´t recognized the M2Tech Hiface I. Well with Raspyfi it didn´t work so I guess the compatibility of DACs is the same.

With Raspyfi there was a way to fix this question, but I was not able to get it.

There was also said that next Raspyfi would include this Hiface I compatibility “out of the box” (well it is not a DAC but USB-SPDIF interface). Is not the case of Volumio, isn´t it? I dream with that…

Thanx and regards

darej I’m sorry but Hiface I is currently not supported, but you can try the fix on RaspyFi website. Since this is the mainline kernel you should be able to download the sources and compile by yourself…
Anyway I plan to support the first Hiface, but I have major priorities right now… Sorry…
If you however succeed in compiling it I will include it for sure!

Yes, I clicked on “Save changes”. When that did not work I also tried to reboot but still no difference.

That´s right Michaelangelo! In the meantime I´ll be using the ODAC, it works fine.

Thanx a lot.

When I connect my MusicalFidelity V90-Dac with USB (AQVox) on Volumio (Raspy), I can hear the music. But I hear permanent cracking like Grgrgrgrgrgrgr or something like that.
I have changed the Kernel-Module, MixerType, CMedia Fix, RSize/WSize, … But nothing gives positiv effects.

With RaspyFi, it works almost perfect. Really only a few cracks I can hear as I had a vinyl record after change the RSize/WSize to 32768 both.

I have download the Image and flshed it again, but its the same issue.
What can I check to eliminate the error ?


It appears that the current Volumio kernel is just a step backwards…

I’ll release a new image soon!

Thank you for the great work. Volumio is perfect!
So I come away from my Squeezebox;-)

It sounds really excellent, I enjoy the music very much!
Only the first passage of the NAS scan takes several minutes (ethernet). After that the scan takes only a short time. My Flacs (approx. 300GB/5600 tracks) took about 10 min and after that only a few seconds. (SBM/CIFS)
But the small cracks in between are in Flac 24/96 still audible, but less than with RaspyFi. It is not very bad, but clearly audible. I’ve tried various ways but none has brought an improvement. The CMediaFix, mixer type, Gappless = Off, DSP = Off, etc., all did not help. Nothing has really changed in each case.
The mount options R / W Size I have also tested and placed on both 32768. So it was recommended by someone in the forum of RaspyFi. But I’ve found that the sound quality suffers heavily. The bass ect. are blown away.
Do you have the may also notice?

I use the Volumio 1.1 Beta, Raspberry-Pi (B) with a Musical Fidelity V90-Dac (M2496) (Aqvox USB cable), Flac 24/96 apply.

Is the Raspberry Pi unsuitable for Volumio?

Greetings from Switzerland

Unfortunately there are no kernel-headers available for the default kernel.
We still need the 3.6-trunk-rpi to compile snd-usb-hiface.ko.
Is there any chance to get the headers of the default-kernel?


I’m pretty convinced to build Volumio’s next version with mainline kernel. So we’ll also get all the sources…

I´m going to try that. Can I know the LOGIN and/or PASSWORDS for changing things as administrator?? I tried with the ones in RaspyFi (su + root) but these don´t work… :confused:

Thanks a lot!