DAC died after plugin install. Can't get it back

Volumio Information

Volumio Version: 2.806
Hardware: Raspberry Pi 3B+
DAC: Sainsmart Hi-Fi DAC Module (HifiBerry DAC clone PCM5102)

I upgraded Volumio to the recent version and everything was working well. Then I installed a equalizer plugin and everything quit working. I removed the plugin, but have been unable to get any sound out of the DAC since.

I can’t even change to headphone output and get any output.

I have rest to factory settings several times. I have flashed the SD card again and got no difference.

Is there any possibility that some change was made to the DAC that is persistent, or that something is being stored in the Pi that is keeping it from working? I’m out of ideas to try.

I can access the board by local terminal, but don’t know where to look there. The volumio command line seems to work but still no audio output.

Have you enable i2s DAC and then select your DAC?

Yes. I think I’ve tried every possible setting, HifiBerry DAC, HifiBerry DAC+, Generic I2S DAC, etc. I’ve tried the volume mixer setting as software and hardware (I believe it needs software.)

As I said, I’ve even tried to use the headphone out setting just to see if the problem is only with the DAC.

If I play a source such as an internet stream, it shows the “Started playback of …” message. Sometimes it looks like it is playing. Sometimes it goes back to showing the Play arrow as if nothing is playing.

Can you enable ssh and post the content returned by
aplay -l

info, PCM5122 provides a hardware mixer.

Here’s what I got:
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/3
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
card 2: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]
Subdevices: 0/1
Subdevice #0: subdevice #0

I think you have to use HifiBerry DAC+ because the one configured is a pcm5102 (no hw mixer).
The reboot.
Check if mixer is ‘digital’.

I see pcm5102 in the output. I got 5122 from the web page of the manufacturer. They must have updated their product. Mine is about a year old.

My observation has been that it always wants software mixer as hardware never worked. I had saved screenshots when it was working, because this always is confusing, and they show I was using HiFiBerry DAC with Software mixer when it was working.

Still stumped because even burning a new image on the SD card has not fixed this.

Digging into it further (literally) I opened the case up and looked closely at the board.
It is marked as a PiFi DAC+ v2.0 not the Sainsmart module at all. The chip on it is clearly marked PCM5122.

I had looked at my Amazon account history to see what I had bought and that said it was a Sainsmart. Apparently, they sell them interchangeably.

I have another one that I have set up as a bluetooth player. I’m going to play around and see what it is. It works so well, I’m reluctant to mess with it much, though. It goes for weeks and weeks untouched and whenever I pair my phone to it, it just works. I can’t say that about Volumio at any version, but I had high hopes for this latest version.