[collected] improvements for wireless

Hi Again,

there are 2 simple “Hacks” that will possible improve Wireless quality on some Setups.

first i added “wireless-power off” to /etc/network/interfaces
AND
“wireless-rate 11M fixed” {can also be 2M or anything else}
…i have using small fixed rate wifi-connections for years, i guess the algorithms of dealing with changing rates are not the best one -> after i added this 2 Lines i have no interrupts recognized while listening.

I would Suggest the following 3 new Features

1.) always "wireless-power off" to disable WIFI Powermanagement 2.) allow configuring wireless-fixed-rate via the WebUI 3.) for "Debugging" it would be nice if there are any hidden WEBUI Features to show WIFI Quality, Rate, etc

again Greetings from Vienna
MarioMM

Thank you Mario!!! That is a clever report. Wireless-power is already enabled in some setups… But the others are definetely good additions!
Thanks and also for the startup sound!

Hi MarioMM,

Unfortunately this didn’t do the trick for either my Raspberry Pi + Edimax adapter or my Cubox-i4 Pro with internal wifi.
Thanks to kerampont I found a solution on the forum for the RPi + Edimax combo : http://volumio.org/forum/losing-wlan-connection-after-moment-raspberry-t807.html#p3591
But since i switched to the Cubox-i i had to reboot frequently the little box after loosing the network connectivity … until i spend an afternoon focused on this issue. And finally i found a solution here : http://ubuntuforums.org/archive/index.php/t-1686641.html.
Here is the trick, and even if i didn’t test it with the RPI, i think this solution works as well :

[code]sudo mkdir /etc/pm
sudo mkdir /etc/pm/power.d
sudo nano /etc/pm/power.d/wireless

#!/bin/sh
/sbin/iwconfig wlan0 power off

sudo chmod +x /etc/pm/power.d/wireless

sudo nano /etc/rc.local

Disable Wifi power management at startup

sleep 10
iwconfig wlan0 power off[/code]

For your info, the first part (before /etc/rc.local) may not be necessary as it is related to laptop power management when the charger is plugged or unplugged.