Cannot enable cron daemon

I can’t seem to get cron to start automatically at startup:

I’ve installed the cron package

sudo apt-get update sudo apt-get install cron

I’ve tried making it start on boot with

 update-rc.d cron defaults

and when that didn’t work I tried adding it a line to /etc/rc.local

/etc/init.d/cron start

The weird thing is that the @reboot line I’ve got in crontab -e will run (executing a script), but the following line which executes the script every hour will not! When I check

ps -ef |grep cron

I see that this is because cron is not running. If I start cron manually from the command prompt as root (/etc/init.d/cron/start) it starts running smoothly; so no problems with the script or with cron itself, but the cron daemon doesn’t seem to be starting cron at boot…

ANY AND ALL ADVICE IS WELCOME, no matter how trivial it might seem (I’m sure i’ve forgotten to enable the most basic thing!)

Cheers! :slight_smile:

I had the same problem.

you can fix it by commenting out the kill command for cron in script.

See loza’s update on my thread here for more details.

I did try it and it works great.

@ehubin, cheers mate! that did the trick!!