BeagleBone Black (Rev B) Wi-Fi Connection Issue

Initial setup and logon via my browser works very well. Great job!

Am having trouble with setting up a wireless connection. Put in SSID, security, and password and when I select “save” it puts up a “connecting” screen animated logo, but just sits there without actually connecting (tested once for >30m). Thought power may be an issue, based on a few sites I read, but that doesn’t seem to pan out. Tried two different wireless cards, two different USB hubs (one with separate A/C power, one not), with a wireless card the only USB connection, three different ways to power the BBB (A/C, USB, and USB+A/C). One of the wireless cards has function LEDs when being used and they never lighted up when trying to connect wirelessly. What else may I try?


The USB wireless adaptor I purchased from Logic Supply with my BeagleBone Black uses an [apparently] Volumio-unsupported Media Tech MT7601U chipset (see … edit?pli=1). The other USB WiFi adaptor I tried with Volumio (Broadcom 4323) appears to also be unsupported by Volumio.

Any suggestions on how to get the MT7601U to work with Volumio would be greatly appreciated.