Audio CD Player Funktion 3.198

Hy I want to hear a Audio CD with my Raspberry Pi 3 with Volumio v3198 but the cd player search and search but nothing is happening. I had 3 cards flashed with 3 different images. ( 3.197/3.226) It’s the same problem.2.917 it’s Working. Sorry for my English.

Thanks

Processing: logs.volumio.org/volumio/PvGwfGQ.html…

http://logs.volumio.org/volumio/PvGwfGQ.html

just before the failure, the kernel reports:

Feb 14 15:16:59 jrgenpi kernel: Under-voltage detected! (0x00050005)

Perhaps you have a power issue?
The Hitachi drive has been detected and initialised properly as far as I could see.

Thanks for your time.

Hello, I’ve tried everything again. I can rule out power problems. CD playback with v. 2917 works without problems. But v3.198 SEARCHES AND SEARCHES The player but nothing Happens. Hope someone can help me. thank you

Thanks for reporting. We are looking into it and issue a fix for the next release

Thanks for your time and Answer Michelangelo.

This helps me:
When installation NanoSound CD on volumio version 2.882 or later,
there is a bug which prevent a successful installation. Fortunately, there is a work around:

Method 1: Edit sources.list manually

  • Using a terminal software such as Putty, SSH into volumio.local,
    default user name and password are both “volumio”
    SSH into volumio
  • add temporary the debian stretch source to install the dependecies

sudo nano /etc/apt/sources.list

  • add this line:

deb Index of /raspbian stretch main contrib non-free rpi

  • update the package list:

sudo apt-get update
sudo apt-get install binutils
sudo apt-get install libstdc+±4.9-dev
sudo apt-get install gcc-4.9 gcc g+±4.9 g++ dpkg-dev

  • remove the line again from source from sources.list

Method 2: Run Script

  • Make sure NanoSound CD is not installed
  • Using putty or terminal in mac, ssh to volumio.local
    o eg. in terminal in mac , run:
    o ssh volumio@volumio.local
    o when asked about continue connecting type: “yes“
    o Enter password: “volumio“
  • install unzip and dos2unix
    o sudo apt-get install unzip
    o sudo apt-get install dos2unix
  • get the script
    o wget https://community.volumio.org/uploads/short-url/dxLoHCHS6zbt8HGZGoyELmLacvo.zip
  • unzip the file
    o unzip dxLoHCHS6zbt8HGZGoyELmLacvo.zip
  • Above will unzip a file called Workaround_BuildEssentials.sh, Make it executable
    o chmod +x Workaround_BuildEssentials.sh
    o dos2unix Workaround_BuildEssentials.sh
  • Run it
    o ./Workaround_BuildEssentials.sh
  • Install NanoSound CD from repository
    Alternatively, you may also use the previous version of volumio which do not require above workaround.

I STRONGLY ADVICE AGAINST DOING THIS. IT WILL BREAK YOUR VOLUMIO INSTALL IN MANY UNPREDICTABLE WAYS.

Don’t do it

I don’t make it. I’ll wait for the official Update. Thanks Michelangelo

Thanks for your patience.
It has been fixed, the new release with this fix will be out next week.

2 Likes

Please and Thanks for the information. Best wishes.

1 Like

@volumio

v 3.233 No Metadata at CD player. I hope you can fix it AND When is the Nanosound CD Plugin in the Plugin List.

@volumio

V3.236 Beta

Bluetooth playback music not sincron with cover and CD player playback STILL NOT working. NO button available Please fix these bugs now. Stay with version 2.917 for now. Thanks

Hi Jurgen,
we tested this functions extensively after your report, but we don’t get to replicate the bugs you report.

To fix those, we need more datas, especially logs:

Can you please

  1. Insert a CD, then after 20 seconds ,send a log:
    Sending logs for troubleshooting - Volumio Documentation
    Paste the link here
  2. Play audio with bluetooth, hen after 20 seconds ,send a log:
    Sending logs for troubleshooting - Volumio Documentation

Thanks

1 Like

seems the log was not ready yet. won’t open

1 Like

logs.volumio.org/volumio/VyQzrOI.html.

Thanks for your answer and Time.

At.2917 it’s working but with V3. Xxx not working.

@volumio

V3.237 Beta?

CD playback works now. Some things don’t quite work for this. Ripping button no function. No metadata available.

Thank you very much for your efforts

1 Like

@volumio

V3.238 Beta?

Is the same Problem Wit the Ripping Button. No Funktion. No Metadata. Bluetooth is now working.

@volumio

V3.239 Beta?

Ripping Button no function. No metadata.

Virtuoso Account Available.
CD playback works, Bluetooth works.

Please Fix this problems.

Thanks

Jurgen, can you please send logs after you try ripping?

Also, can you provide the title of the CD you are trying to rip?

Thanks