Attempting to setup DAC that isn't on GUI but is in the dacs.json file

I download and built the latest version of Volumio. I have an a V2 version that was built and has the selection of the DAC but V3 version doesn’t have that. I read documentation which speaks of configuring via command line, but no real specifics of the work to do that. Can anyone point me in the right direction? Thanks!!

what DAC are you referring to?


A little explanation

due to some structural changes required by the new Raspberry Pi kernel, on Volumio3 a new parameter has been implemented on every entry on the dacs.json file (alsacard)

if the new parameter is empty, the corresponding DAC will not be shown on the dropdown list of available DACs. This is the case of TAUDAC.

most of the I2S DACs have been filled with this additional parameter, with help from the community. For some of them this wasn’t possible, because the team doesn’t have all the DACs, and no entry was provided by the community.

If you can help to provide the required parameter, I can create the pull-request for adding the alsacard entry for TAUDAC.

  1. connect the SD-card to the PC
  2. open the file “userconfig.txt” with Notepad++ (under Windows) or with any text editor (under macOS or Linux)
  3. add the string “dtoverlay=taudac” on a new line and save
  4. insert the card on the Raspberry Pi, power it up and then follow the instructions from the initial post of this thread

Darmur, thanks so much for responding with the information. Of course, I would be happy to provide the details needed for the pull-request. I won’t be able to provide this until next week, but will accomplish this first chance I get.

no problem, please take your time!

Just posted as requested. Thanks

here the pull-request

you should wait for the next stable release to have your TauDAC supported

the pull request has been merged, TauDAC will be available in the next release