Album name shows as * on Album screen


hope I can get some help.

On the album view I have a an album name that is displayed as * and when I click on this it shows the tracks from the album plus a lot of albums that follow it. The next album in my library is also missing.
I have updated the system, checked all the file tags and re-scanned the music library without any change.
On the artist view all is as it should be
Anybody got any suggestions ?


I find it helpful to have the music sorted as follows:




Then make sure the files in each of the Albumname folders has a matching (including case sensitivity and & vs and type matching) Artist and Album tags.

Check for files with Album Artist instead of Artist.
I prefer to use only Artist and leave Album Artist blank except for compilations by various artists, then I use Various Artists as the Album Artist, and the actual song artist for the individual track Artist tags.

Look for wav files, not all tags seem to work properly in wav files. I found it best to stick with only flac and dsf files on Volumio. They accept all the tags I need and work properly with Volumio.

Check each album for each artist, to make sure the Artist and Album tags are consistent.
Look at the files/tracks in those mystery * album, try and see what is missing or incorrect in the tags of those files/tracks.

I had similar issues with my USB music store until I went through and carefully cleaned up the tags and file types.

Thank you for that. I have a mixed set of files, WAV, FlaC and mp3. I recopied the CD which was showing an * and was WAV encoded to FLaC as suggested and it now looks correct. Hurrah.
However, the next WAV encoded CD is now showing an *. I will need to go through and re-encode a few more CDs, 1000+ tracks :frowning:
There must be a bug somewhere but what and how I don’t want to think about too complex for me.


Yes, it’s a pain if you have a lot of wav files that don’t seem to work well with tags under Volumio.
You can use EAC (Exact Audio Copy) to convert your wav albums to flac as a batch.
Open EAC, then drag and drop the whole album full of wav files into the window and it converts to flac. Set up a test folder and try it to get the hang of how it works before you let it loose on your music collection.

Thanks for the suggestion. Tried EAC to convert but it appears to wipe out the Metadata. I am probably not setting the options correctly.
Found that dBpoweramp converter works and leaves the metadata intact. Will go with that for now as I can do a folder of various artists easier with that.


I still have a * in artist name under a large ? icon in the Album view screen. Clicking on it reveals an album that exists already in the catalogue. I have checked the tags several times and re-written them to disc but the album stays there. Will try a shutdown and re-start but am baffled by this.


I think I had something similar at one stage.
You try the refresh/recan thing under settings (sources I think).
Also check that something like
Artist = Echo & The Bunnymen
Album Artist = Echo And The Bunnymen

That sort of thing would likely make it list twice.