2.598 (26-07-2019) breaking on Raspi 1


I was upgrading to 2.598 (26-07-2019) on my Raspberry Pi Model B Rev 2 (000d). this is failing with a weird error message on reboot. see the attached.

I tried installing from scratch using various SD cards, but this is reproducible, so it seems like the new version of Volumio breaks on that old Pi.

I’ve now gone back to 2.586 from updates.volumio.org/pi/volumio/2 … pi.img.zip


The same on my Rpi Zero

Update from 2.586 or 2.587 to 2.598
Update from 2.565 (clean install) to 2.598
Clean install 2.598
All failed

So far I have updated 2 Rpi 3 and they works fine

The same problem with me. Raspi Zero keeps hanging while booting with update 2.598. All updates before were no problem :frowning:

Same on RPI2. Is it possible to fix or do I need to reinstall?

Great. My Pi ZeroW is dead now too.

Read some of the other forum posts. Doing a clean reinstall yields exactly the same result. This isn’t an upgrade problem, the release just simply doesn’t work on any first generation raspberry pi. Since it’s been 4 days and the developers haven’t even acknowledged the incompatibility, I have to assume that they don’t consider this to be a problem. I’d’ve at least put a check into the upgrade so that it doesn’t even try to upgrade on a first gen rPi.

I just did a update from menu-system and if this release doesent work the it shuld skip the autoupdate

Let’s read release notes changelog-t1575.html
I see no info about dropping support for RPI Zero* or RPI2, so logically this is a bug with v. 2.598 that should get solved.

@gkkpch Said in another thread

@sonoskiller: thanks (your were faster), hope we really nailed the issue…

Can I downgrade from terminal och do I need to reflash my card with a older version?

It just took out my Pi Zero too via menu update.

I’ll roll back to 2.586 for now until it’s fixed.

Editted to add - back up and running again, and (presumably) thanks to the newish account set-up, even set itself up once reconnected.

After installing version 2.599, volumio works again fine on my Pi Zero :slight_smile:

I can confirm 2.599 working ok on Raspberry Pi Model B Rev 2 (000d).
thanks for the fix.

Many things broken in the latest release (2.599) related to updated plugins on RPi3+. Radio Paradise plugin works but floods the Volumio log with error messages when streaming FLAC. Installing and enabling the GPIO control plugin (using GPIO18) kills the audio output. Installing the Amplifier switch plugin results in a second entry in the installed plugin list with a second entry with the unrelated Radio Paradise entry… what?

All in all, updating Volumio and plugins was a disaster. Tried a fresh install, same issues. This all stuff that have previously worked flawlessly.

Is it possible to revert to whatever was current Volumio and plugins from a few months back?

I’m getting crashes again on 2.599 on my Pi ZeroW.

Reboot and it will run for a while (anything between a few minutes and several hours) and then just completely stop responding (no ping, no connection). This is both when it’s just sat idle and when it’s playing an internet radio stream.

Will roll back to 2.586 for a while to test the SD card out, and see how it goes.


I’ve got a Raspi 1 and exactly the same problems. Newest version of Volumio booting up without problems, then I configure it, register my >50k titles lan-library and let it index it. Lasts a long long time, approx. 10 hours or more. Afterwards, if I ever reboot the device, it won’t come up again, hangs at some obscure point, won’t be reachable neither via webgui nor via ssh, “connection refused”. It’s registered correctly in my LAN, the router displays the correct IP. Only thing that helps at this moment is to reflash the card.
Did this several times, nothing changed, so I reverted to 2.586 as suggested here, and it’s back to normal! Working flawlessly. Indexes the whole library in less than an hour, no problems with rebooting, menus much faster etc.

Conclusion: Versions after 2.586 are incompatible with Raspi 1. Don’t update.

To report back, 2.586 has been rock solid since I rolled back.

So my conclusion is also that there’s something unstable on 2.599 with the single core/old Pi’s.

I see now 2.619 is out so will take it up to that and see how that one goes for stability. But keeping the img file for reliable old 2.586 around just in case…

Hi Darren,

I already tried 2.619, it had the same problem.

This is due to the new kernel for PI4.
We are building a new image with updated kernel