[1.5] Volume Control Issues for Spotify?

A few people have brought this up - just wanted see what’s going on. If you have this problem, please try to SSH into your player and run ‘alsamixer’. Then report the information in the top left corner, and whether the volume bar moves up and down as you control the volume from the webUI.


logged into volumio via ssh and typed in alsamixer -->alsa window appeard, saying “this sound device does not have any controls”

tryed to press f1, f2, f3, f4, f5 --> nothing happened, always jumped back to command screen.

then I pressed f6 --> the second screen ( lqqqqq Sound Card qqqqqk) appeared but nothing happend, at least nothing that I could see.

Screenshot 2 Alsa Mixer.PNG

I also enterd a couple of alsa commands - maybe that helps you.
Volume control still works for normal playback with data from the usb stick and webradio, only spotify causes trouble.
I’m happy to help if you tell me what to type into the command line!
Screenshot 4 Alsa Mixer.PNG
Screenshot 5 Alsa Mixer.PNG

If you are using Putty, you might need to configure the function keys. In the session settings, try going to Terminal->Keyboard, and set the function keys and keypad to send Xterm R6 compatible commands. Running the command ‘amixer’ might also give us some useful info.

I actually use a USB speaker (Vanatoo T1), so am not too familiar with how the I2S boards work, but we can try to interface directly with MPD. In your console, type ‘telnet localhost 6600’ to connect to the MPD daemon. Give it the command ‘setvol X’ where X is your desired volume, and then do ‘status’ to see if the change registered. To close the socket, type ‘close’.

You might also give a try to switching back to hw mixer…


I have the same issue. volume controls on volumio.local/ work for the web radio but not for Spotify. Tried changing between the different mixer options but no luck.

Raspberry Pi model B
Card: snd_rpi_hifiberry_dac

Currently running spotify on clients instead (mac book, ipad, iphone) and using airplay. The volume on the client can then be used to adjust volume.


Give this a shot and let me know what happens. The Spotify playback actually uses the MPD volume control, so it’s not immediately clear to me why this problem occurs.


I log into the MPD daemon like you suggested, and tested the commands that you gave. Maybe this will clarify.

I can use the setvol command to change the volume to whatever, this is reflected on the volume knob on the web interface also. No issues.

But, I can also use the knob on the UI to change the volume to whatever and this is reflected when I do the status also in the MPD daemon console. So if I change the volume to 5 on the web UI and do status, it shows as 5 on the console output from the status command.

The issue is that none of this affects the volume experienced from the speakers, it plays at what appears to be full volume regardless of what is on the volume knob in the UI or returned from the status command.

This issue is not experienced using the Volumio webradio. I do not have other sources to test but I imagine it is specific to Spotify.

If I use the spotify client on an apple product (mac, ipad, iphone) and use airplay, then the volume can be adjusted from those clients without any problem. I would prefer to use the volumio web UI as we are a mixed family (IOS and Android) :slight_smile: .

Hope that helps clarify.


Greetings, I am also experiencing full-volume playback from the Volumio Spotify feature - but WebRadio volume is controlled fine with the volume knob.

I have confirmed via the MPD telnet session that the volume setting in MPD is synchronized with the volume knob in the U/I.

Upper left corner of my alsamixer is:

Card: Schiit USB Audio Device Chip: USB Mixer

AirPlay: volume reflects client device volume
WebRadio: volume is set by Volumio knob
Spotify: volume appears to be full-on no matter the volume knob setting

Is there any hope for the flowers?



Same here,

Spotify 100% volume, cannot alter with gui or alsamixer.
Webradio & NAS works as should, i can alter volume with GUI, but not alsamixer.

Changing volume in mpd is shown in gui, no effect on actual volume
Changing volume in alsamixer is not shown in gui, also no effect on actual volume.

Aalsamixer upperleft corner:
USB Audiodac
USB mixer

I use Chordette Gem USB DAC.

Hope this will be fixed soon.


Hi together

Is there already a fix out there ?
I have the same problem… Software mixer works great with webradio and Network mounts but on Spotify there is no reaction ?
Hifiberry Amp doesn’t like 100% a long time neither do the neighbours…

Please help
Regards Thorsten

Software mixer affects just mpd’s output. So this is why it doesn’t work with spotify.
The only fix is use hw mixer (which will change alsa’s mixer).
Are you guys able to use hw mixer with your devices ?

Hi Michelangelo

Thanks a lot…
I thought HW Mixer meant to be something external

Took this link to get it running

Works fine on my config with Hifi Berry Amp.
Not that much of Volume Control but works fine for me.
Finally Spotify Mobile with my little Ghettoblaster…

Great Work by the way with Volumio
I like it

Regards Thorsten

I have a HiFiBerry DAC,
With the HW mixer setting, the volume knob always jumps back to 100%. It seems that HW volume control is not supported by this DAC.
With the SW mixer setting, Web Radio can be volume controlled, but with Spotyify the output is always 100% regardless of knob setting.
I would appreciate a solution

Alsamixer upper left corner:
Card: snd_rpi_hifiberry_dac


I am also having issues here. I am on rpi b+ with hifiberry dac+ and cannot control the spotify volume. Settings is set to software mixer. Is there a fix out there yet. ?

Yeah this appears to have something to do with the DAC support for hardware/software mixers. Could you please look in you ‘/etc/spopd.conf’ file and report what the ‘audio_output’ is set to?

Possible options are ‘ao’, ‘sox’, and ‘oss’. Give some of the other options a shot!

It is originally set to “ao” - that results in uncontrollable spotify volume
“sox” removes spotify from the library and gives me no option to test (updating the library won’t help)
“oss” crashes spotify

Copy, thanks for the update. I don’t have a good answer for you at the moment, but we are working on some code which should bypass this problem altogether! :slight_smile:

great - thank you so much for your work!
I am really looking forward to the Spotify Fix - as it is currently unusable to me.
keep up the great volumio!!!


experiencing the same issue (RPI B, HifiBerry DAC). Spotify runs on full volume.
Also, the volume for an incoming airplay stream can´t be influenced by volumio in my installation. (fresh install with volumio image from last week, Kerne 3.12.35 as far as I recall).
Are there any workarounds?

The problem with feeding spotify and other input via airplay, is that the granularity of control on the iOs device in low volumes is just non existent.
So if I turn up my amplifiers to a reasonable (loud) maximum level, the lowest bar in volume control on the iPas/iPhone ist still far too loud for background listening (and I can´t control the volume of my amplifiers as they are installed in the ceiling).


Any progress on this issue?
Just created a spotify account and started to play some music I hadn’t heard for ages.
2x 300w doesn’t go down well with 3 kids at 10 o’clock in the evening. The quickest I’ve lunged for the amp off switch in ages!