X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

Cool. Will it be included in the next release?

I have an old Mini86 with 500 GB music files on the internal volume which i like to upgrade to Volumio 3.

Unfortunaly to backup the files over network with samba does not work. The connection always breaks due to timeouts.

Any recommendations how to backup the internal volume?

Guess the OS is on the same volume as the data files?
If so, then you can only do this over the network,
The timeouts, are you connecting via WiFi or copper.

Guess the OS is on the same volume as the data files?
Yes, correct.

The timeouts, are you connecting via WiFi or copper.
Both

Would it be possible to connect an external USB hard drive and copy the data files over the shell to the external drive? If somebody could provide me the paths and commands? I have no idea where the data files are located.

If you connect a powered USB device this is possible.
You media is located at:

cp -r /data/INTERNAL /media/<name of USB thing>
1 Like

I’ve been using a 2006 MacMini with Volumio for years. It has 4Gb ram, Cor2Duo processor, 2.1Ghz type. In it, the system is set to a 1Tb SSD, music is everything. It drives a Topping D10 DAC, I have no problems with it except powering it up. You have to de-energize the thing for that, so I never turn it off. He has a beautiful voice and is also flashy. It has an external WI FI, and the internal CD DVD player plays CDs or rips them perfectly. Is breast better than this?

I had this error too. I solved my miniPC problem by changing the UEFI boot option (changeable) to traditional, old-fashioned Boot. From then on, all my problems were solved. My machine is a small Chinese machine. Your house is nice. I don’t know his name.

@gkkpch

Hi Gé,
Experimenting to get OLED running on a x86 (HP EliteDesk…) machine, but run into a snag. Instead of me breaking things I thought let’s drop the question.
Need to run make to get a USB-I2C driver installed, but it keeps erroring out:

volumio@volumio-x86-s2:~/i2c-ch341-usb-master$ make
make -C /lib/modules/5.10.139-volumio/build M=/home/volumio/i2c-ch341-usb-master modules
make[1]: Entering directory '/lib/modules/5.10.139-volumio/build'
make[1]: *** No rule to make target 'modules'.  Stop.
make[1]: Leaving directory '/lib/modules/5.10.139-volumio/build'
make: *** [Makefile:9: all] Error 2

Running V3.378,
uname -r = 5.10.139-volumio
Kernel headers = None.

if I run below command, only available 4.19.x kernel-headers are shown
sudo apt search linux-headers

Failing:

volumio@volumio-x86-s2:~/i2c-ch341-usb-master$ sudo apt-get upgrade linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-5.10.139-volumio
E: Couldn't find any package by glob 'linux-headers-5.10.139-volumio'
E: Couldn't find any package by regex 'linux-headers-5.10.139-volumio'
volumio@volumio-x86-s2:~/i2c-ch341-usb-master$

Any safe way to get the correct headers loaded (V5.10.139)?

let’s take this on PM and report the results here (when we have some) as I’m fairly busy with things besides x86 support. Can take some time…

Thanks for your support, Loading the kernel modules and creating the symbolic link did the trick.
USB driver is loaded and device is recognized:

Bus 003 Device 003: ID 1a86:5512 QinHeng Electronics CH341 in EPP/MEM/I2C mode, EPP/I2C adapter

volumio@volumio-x86-s2:~/i2c-ch341-usb$ ls -l /dev/* | grep ch341
crw-rw---- 1 root ch341   254,   0 Nov 24 14:40 /dev/gpiochip0
crw-rw---- 1 root ch341    89,   9 Nov 24 14:40 /dev/i2c-9
volumio@volumio-x86-s2:/dev$ sudo i2cdetect -l
i2c-3   i2c             i915 gmbus panel                        I2C adapter
i2c-1   i2c             i915 gmbus ssc                          I2C adapter
i2c-8   i2c             AUX C/port C                            I2C adapter
i2c-6   i2c             i915 gmbus dpd                          I2C adapter
i2c-4   i2c             i915 gmbus dpc                          I2C adapter
i2c-2   i2c             i915 gmbus vga                          I2C adapter
i2c-0   smbus           SMBus I801 adapter at f040              SMBus adapter
i2c-9   i2c             i2c-ch341-usb at bus 003 device 005     I2C adapter
i2c-7   i2c             AUX B/port B                            I2C adapter
i2c-5   i2c             i915 gmbus dpb                          I2C adapter

Hi I’m not sure this is the right place to post this, but i am really struggling to install x64 volumio on a HP t520 thin client. I know the t520 works because it boots other img files and i already have one running volumio 3.0. I looks like the issue might be multiple partitions that are created on the usb drive when the image is burned to it.

Do you know of an issue??

Regards
Chris

How are we supposed to help with “it’s not working”, surely you can do better than that😉
What do you mean with not working? Not booting? Stops with error message(s)? Nothing happening at all?
Why do you think the partitions are the issue?
Volumio has 3 of them.

You know something forget it, I’ve fixed it, there is no need to be so rude!!

when you feel this was rude, then sorry. But asking for help without supplying information is not very clever either. Curious to hear your solution, others could profit.

This post was flagged by the community and is temporarily hidden.