wlan problem Edimax EW7811UTC


I’ am running volumio 1.55 on a raspi 2 and tried to connect to my wifi with the wifi dongle Edimax EW7811UTC, was, after entering the SSID/PW in the GUI and resarting did not work.
It seems however that the device was recognized - lsusb returns:

Bus 001 Device 004: ID 7392:a812 Edimax Technology Co., Ltd

Module Size Used by nfsd 256175 2 ipv6 341384 40 snd_bcm2835 19769 0 snd_soc_bcm2708_i2s 6701 0 regmap_mmio 2969 1 snd_soc_bcm2708_i2s snd_soc_core 132622 1 snd_soc_bcm2708_i2s snd_compress 7736 1 snd_soc_core snd_pcm_dmaengine 3287 1 snd_soc_core snd_pcm 74825 3 snd_bcm2835,snd_soc_core,snd_pcm_dmaengine snd_seq 53561 0 snd_seq_device 3650 1 snd_seq snd_timer 18157 2 snd_pcm,snd_seq snd 52116 7 snd_bcm2835,snd_soc_core,snd_timer,snd_pcm,snd_seq,snd_seq_device,snd_compress bcm2835_gpiomem 2995 0 i2c_bcm2708 5014 0 uio_pdrv_genirq 2966 0 uio 8235 1 uio_pdrv_genirq

Does anybody have an idea how I can get the wifi connection running?
Thanks in advance!

I did some further research,

as it turns out, there is a dedicated Linux driver available for this adapter:
edimax.com/edimax/download/d … ew-7811utc
I did however not have any luck following the installation instruction that came with the driver.

I would greatly appreciate if somebody has any tips how to tackle this issue!

Same issue running 1.55, however I can use this same USB WiFi dongle with a Raspberry Pi 2 on OSMC successfully. I believe it’s due to the fact that the Realtek 8812 driver isn’t installed / part of the 1.55 image. I’m a quasi-novice Ubuntu / Linux user however, so my terminology might not be accurate, but prior to OSMC releases supporting that 802.11ac dongle (Edimax EW-7811UTC AC600), the Realtek 8812 drivers had to be installed manually so the adapter would work.

Haven’t tried install the 8812 driver yet on 1.55, but will do so and see what happens…


did you manage to get it working?

I was trying to get it working under Raspbian but was not successful…

It seems however that there have been some folks out there who managed to get it running.